Commit c9ffb654 authored by Matěj Cepl's avatar Matěj Cepl

Add requires to setup.py.

parent 07c68814
......@@ -7,4 +7,7 @@
0.3 2012-03-08
* Excuse me, son, but your tempfiles are leaking !!!
* Also fixing python setup.py test so that it actually does something.
\ No newline at end of file
* Also fixing python setup.py test so that it actually does something.
0.4 2012-03-09
* Missing requires field in setup.py
\ No newline at end of file
......@@ -45,6 +45,9 @@ setup(
cmdclass={'test': RunTests},
classifiers=[
"Programming Language :: Python",
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Development Status :: 4 - Beta",
"Environment :: Console",
"Intended Audience :: Information Technology",
......@@ -52,6 +55,9 @@ setup(
"Operating System :: OS Independent",
"Topic :: Software Development :: Libraries :: Python Modules",
"Topic :: Text Processing :: Markup",
]
],
requires=[
"PyYAML (>=3.09)",
"unittest2"
],
)
......@@ -113,7 +113,7 @@ Read more about TAP and YAMLish here: L<http://testanything.org/wiki>
import logging
import yaml
__version__ = "0.3"
__version__ = "0.4"
__author__ = "Matěj Cepl <mcepl_at_redhat_dot_com>"
class _YamlishLoader(yaml.loader.SafeLoader):
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment