eid-mw-9999.ebuild 2.39 KB
Newer Older
1
# Copyright 1999-2021 Gentoo Authors
Palica's avatar
Palica committed
2 3
# Distributed under the terms of the GNU General Public License v2

4
EAPI=7
Palica's avatar
Palica committed
5

6
inherit autotools desktop gnome2-utils xdg-utils git-r3
Palica's avatar
Palica committed
7 8 9 10 11 12 13

DESCRIPTION="Electronic Identity Card middleware supplied by the Belgian Federal Government"
HOMEPAGE="https://eid.belgium.be"
EGIT_REPO_URI="https://github.com/Fedict/${PN}.git"

LICENSE="LGPL-3"
SLOT="0"
14
IUSE="+dialogs +gtk p11-kit"
Palica's avatar
Palica committed
15 16 17 18

RDEPEND=">=sys-apps/pcsc-lite-1.2.9
	gtk? (
		x11-libs/gdk-pixbuf[jpeg]
19
		x11-libs/gtk+:3
Palica's avatar
Palica committed
20 21 22
		dev-libs/libxml2
		net-misc/curl[ssl]
		net-libs/libproxy
23
		>=app-crypt/pinentry-1.1.0-r4[gtk]
Palica's avatar
Palica committed
24 25 26 27 28 29 30 31 32 33 34
	)
	p11-kit? ( app-crypt/p11-kit )"

DEPEND="${RDEPEND}
	virtual/pkgconfig"

REQUIRED_USE="dialogs? ( gtk )"

src_prepare() {
	default

35
	# xpi module : we don't want it anymore
Palica's avatar
Palica committed
36 37 38 39 40 41 42 43 44 45
	sed -i -e '/SUBDIRS/ s:plugins_tools/xpi ::' Makefile.am || die
	sed -i -e '/plugins_tools\/xpi/ d' configure.ac || die

	# hardcoded lsb_info
	sed -i \
		-e "s:get_lsb_info('i'):strdup(_(\"Gentoo\")):" \
		-e "s:get_lsb_info('r'):strdup(_(\"n/a\")):" \
		-e "s:get_lsb_info('c'):strdup(_(\"n/a\")):" \
		plugins_tools/aboutmw/gtk/about-main.c || die

46 47 48 49 50 51 52 53 54 55
	# Fix libdir for pkcs11_manifestdir
	sed -i \
		-e "/pkcs11_manifestdir/ s:prefix)/lib:libdir):" \
		cardcomm/pkcs11/src/Makefile.am || die

	# See bug #732994
	sed -i \
		-e '/LDFLAGS="/ s:$CPPFLAGS:$LDFLAGS:' \
		configure.ac || die

56 57 58
	# See bug #751472
	eapply "${FILESDIR}/use-printf-in-Makefile.patch"

Palica's avatar
Palica committed
59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82
	eautoreconf
}

src_configure() {
	econf \
		$(use_enable dialogs) \
		$(use_enable p11-kit p11kit) \
		$(use_with gtk gtkvers 'detect') \
		--with-gnu-ld \
		--disable-static
}

src_install() {
	default
	rm -r "${ED}"/usr/$(get_libdir)/*.la || die
	if use gtk; then
		domenu plugins_tools/eid-viewer/eid-viewer.desktop
		doicon plugins_tools/eid-viewer/gtk/eid-viewer.png
	fi
}

pkg_postinst() {
	if use gtk; then
		gnome2_schemas_update
83 84
		xdg_desktop_database_update
		xdg_icon_cache_update
85 86 87

		local peimpl=$(eselect --brief --colour=no pinentry show)
		case "${peimpl}" in
88
		*gnome*|*qt*) ;;
89 90
		*)	ewarn "The pinentry front-end currently selected is not supported by eid-mw."
			ewarn "You may be prompted for your pin code in an inaccessible shell!!"
91 92
			ewarn "Please select pinentry-gnome3 as default pinentry provider:"
			ewarn " # eselect pinentry set pinentry-gnome3"
93 94
		;;
		esac
Palica's avatar
Palica committed
95 96 97 98 99 100
	fi
}

pkg_postrm() {
	if use gtk; then
		gnome2_schemas_update
101 102
		xdg_desktop_database_update
		xdg_icon_cache_update
Palica's avatar
Palica committed
103 104
	fi
}