Commit f5241d11 authored by Daniel P. Berrangé's avatar Daniel P. Berrangé

rpm: fix references to python 2 packages / files

Since we switched to python 3, we should have deps on the python 3 based
packages, and look at the python 3 sitelib directory.
Signed-off-by: 's avatarDaniel P. Berrangé <berrange@redhat.com>
parent d1b329a4
......@@ -36,12 +36,12 @@ BuildRequires: zlib-devel >= 1.2.0, zlib-static
BuildRequires: libtirpc-devel
BuildRequires: rpcgen
%endif
Requires: rpm-python
Requires: python3-rpm
# For virsh lxc-enter-namespace command
Requires: libvirt-client >= %{libvirt_version}
Requires: systemd >= 198
Requires: pygobject3-base
Requires: libselinux-python
Requires: libselinux-python3
Requires: %{name}-libs = %{version}-%{release}
Requires: %{_bindir}/virt-builder
......@@ -108,7 +108,7 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/virt-sandbox-service
%{_bindir}/virt-sandbox-image
%{_libexecdir}/virt-sandbox-service-util
%{python_sitelib}/libvirt_sandbox
%{python3_sitelib}/libvirt_sandbox
%{_mandir}/man1/virt-sandbox.1*
%{_mandir}/man1/virt-sandbox-service.1*
%{_mandir}/man1/virt-sandbox-service-*.1*
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment