Commit 27f2bea3 authored by Andrea Bolognani's avatar Andrea Bolognani

configure: Use a single required version for GLib

Both GObject and GIO are part of GLib, so there's no
point in requiring different versions of the two.
Signed-off-by: 's avatarAndrea Bolognani <abologna@redhat.com>
Reviewed-by: 's avatarDaniel P. Berrangé <berrange@redhat.com>
parent 9019158f
......@@ -10,8 +10,7 @@ AC_CANONICAL_HOST
AM_SILENT_RULES([yes])
GIO_UNIX_REQUIRED=2.28.0
GOBJECT_REQUIRED=2.32.0
GLIB_REQUIRED=2.32.0
LIBVIRT_REQUIRED=1.0.2
LIBVIRT_GCONFIG_REQUIRED=0.2.1
LIBVIRT_GLIB_REQUIRED=0.2.2
......@@ -74,8 +73,8 @@ AC_CONFIG_LIBOBJ_DIR([libvirt-sandbox])
LIBVIRT_SANDBOX_COMPILE_WARNINGS
PKG_CHECK_MODULES(GIO_UNIX, gio-unix-2.0 >= $GIO_UNIX_REQUIRED)
PKG_CHECK_MODULES(GOBJECT, gobject-2.0 >= $GOBJECT_REQUIRED)
PKG_CHECK_MODULES(GIO_UNIX, gio-unix-2.0 >= $GLIB_REQUIRED)
PKG_CHECK_MODULES(GOBJECT, gobject-2.0 >= $GLIB_REQUIRED)
PKG_CHECK_MODULES(LIBVIRT, libvirt >= $LIBVIRT_REQUIRED)
PKG_CHECK_MODULES(LIBVIRT_GLIB, libvirt-glib-1.0 >= $LIBVIRT_GOBJECT_REQUIRED)
PKG_CHECK_MODULES(LIBVIRT_GOBJECT, libvirt-gobject-1.0 >= $LIBVIRT_GOBJECT_REQUIRED)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment