Commit 2e2907d8 authored by Olivier Girondel's avatar Olivier Girondel

Merge branch 'debian-3.32' into 'master'

Debian updates for 3.32

See merge request !86
parents 5c34c0aa d55b30e3
Pipeline #111755859 passed with stage
in 6 minutes and 37 seconds
......@@ -89,8 +89,10 @@ build:stretch:
- cd lebiniou-$VSN
- cp -r ../debian .
- echo 10 > debian/compat
- sed -i "s/>= 11/>= 10/g" debian/control
- sed -i "s/debhelper-compat (= 12)/debhelper (>= 10)/g" debian/control
- sed -i "s/4.4.1/3.9.8/g" debian/control
- grep -v Rules-Requires-Root debian/control > debian/control.tmp
- mv debian/control.tmp debian/control
- debuild -uc -us
artifacts:
name: "lebiniou-stretch-$VSN"
......@@ -110,11 +112,13 @@ build:stretch-test:
- cd lebiniou-$VSN
- cp -r ../debian .
- echo 10 > debian/compat
- sed -i "s/>= 11/>= 10/g" debian/control
- sed -i "s/debhelper-compat (= 12)/debhelper (>= 10)/g" debian/control
- sed -i "s/4.4.1/3.9.8/g" debian/control
- echo >> debian/rules
- echo "override_dh_auto_configure:" >> debian/rules
- echo -e "\tdh_auto_configure -- --enable-test-plugins" >> debian/rules
- grep -v Rules-Requires-Root debian/control > debian/control.tmp
- mv debian/control.tmp debian/control
- debuild -uc -us
artifacts:
name: "lebiniou-stretch-test-$VSN"
......@@ -133,8 +137,12 @@ build:bionic:
- ln -s lebiniou-$VSN.tar.gz lebiniou_$VSN.orig.tar.gz
- cd lebiniou-$VSN
- cp -r ../debian .
- echo 10 > debian/compat
- sed -i "s/debhelper-compat (= 12)/debhelper (>= 11)/g" debian/control
- sed -i "s/4.4.1/4.1.4/g" debian/control
- sed -i "s/unstable/bionic/g" debian/changelog
- grep -v Rules-Requires-Root debian/control > debian/control.tmp
- mv debian/control.tmp debian/control
- debuild -uc -us
artifacts:
name: "lebiniou-bionic-$VSN"
......
......@@ -2,7 +2,11 @@ lebiniou (3.32-1) unstable; urgency=low
* New upstream release 3.32.
* debian/control: Standards-Version: 4.4.1.
* debian/lintian.overrides: Added.
* debian/lebiniou.lintian-overrides: Added.
* debian/control: Build-Depends: Update debhelper-compat (= 12).
* debian/control: Add Rules-Requires-Root: no.
* debian/compat: Remove.
* debian.rules: Add override_dh_shlibdeps.
-- Olivier Girondel <[email protected]> Wed, 09 Oct 2019 17:00:55 +0200
......
......@@ -2,11 +2,12 @@ Source: lebiniou
Section: graphics
Priority: optional
Maintainer: Olivier Girondel <[email protected]>
Build-Depends: debhelper (>= 11), libglib2.0-dev, libfftw3-dev, libxml2-dev (>= 2.6),
Build-Depends: debhelper-compat (= 12), libglib2.0-dev, libfftw3-dev, libxml2-dev (>= 2.6),
libswscale-dev, libfreetype6-dev, libasound2-dev, libsndfile1-dev,
libjack-dev | libjack-jackd2-dev, libsdl2-ttf-dev,
libpulse-dev, libavutil-dev, libmagickwand-dev, pandoc
Standards-Version: 4.4.1
Rules-Requires-Root: no
Vcs-Browser: https://gitlab.com/lebiniou/lebiniou
Vcs-Git: https://gitlab.com/lebiniou/lebiniou.git
Homepage: https://biniou.net
......
lebiniou: package-name-doesnt-match-sonames
# rationale: liblebiniou.so is a private/internal shared object
package-name-doesnt-match-sonames
# rationale: liblebiniou.so.0 is a private/internal shared object
lebiniou binary: package-name-doesnt-match-sonames
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment