Commit aad63da8 authored by M.A.'s avatar M.A. 💬
Browse files

1.2.0 Foundry v9 compatibility

parent 343b6790
Pipeline #426911974 passed with stage
in 17 seconds
# 1.1.1.2 Foundry 0.7.x cross-compatibility
# 1.1.1.1
# Change Log
## 1.2.0 Foundry v9 compatibilty
- Foundry 0.7 compatibility removed
## 1.1.1.2 Foundry 0.7.x cross-compatibility
## 1.1.1.1
- Fix: Permission checking was not done correctly.
# 1.1.1
## 1.1.1
- Fix: Styling of query and result chat cards when the module is disabled.
- Note: FoundryVTT 0.8.x compatibility.
# 1.1.0.2 Hotfix for PF1#782
## 1.1.0.2 Hotfix for PF1#782
# 1.1.0.1 Hotfix for null reference
## 1.1.0.1 Hotfix for null reference
# 1.1.0 Card consistency
## 1.1.0 Card consistency
- Changed: Cards no longer respect selected roll mode but rather configuration in module settings.
- Added: Option to keep NPC cards secret regardless of the above setting.
# 1.0.0 Dedicated module
## 1.0.0 Dedicated module
- Fix: Indirect fix to ammo recovery not being availble on refresh.
......@@ -372,8 +372,8 @@ function onChatMessage(cm, jq, _data) {
bEl.find('.alt').addClass('hidden'); // Hide warning about no longer being possible
settings.recoveryChance.forEach(chance => {
const btn = $('<button />').data('chance', `${chance}`)
.append($('<i/>').addClass('fas fa-dice'))
const btn = $(`<button data-chance="${chance}">`)
.append($('<i>').addClass('fas fa-dice'))
.append(document.createTextNode(` ${chance}%`));
bEl.append(btn);
// Hook buttons. Works poorly if it's not part of the sheet yet.
......
......@@ -5,7 +5,7 @@
"manifestPlusVersion": "1.1.0",
"version": "1.1.1.3",
"version": "1.2.0",
"author": "MKAh",
"authors": [
{ "name": "MKAh", "url": "https://gitlab.com/mkahvi", "discord": "Mana#4176", "ko-fi": "mkahvi" }
......@@ -21,18 +21,14 @@
"system": ["pf1"],
"minimumSystemVersion": "0.77.24",
"minimumCoreVersion": "0.7.9",
"compatibleCoreVersion": "0.8.9",
"conflicts": [
{ "name": "koboldworks", "type": "module", "versionMax": "0.1.12.999", "versonMin": "0.1.0" }
],
"minimumCoreVersion": "0.8.8",
"compatibleCoreVersion": "9",
"license": "LICENSE",
"readme": "README.md",
"manifest": "https://gitlab.com/koboldworks/pf1/ammo-recovery/-/raw/latest/module.json",
"download": "https://gitlab.com/koboldworks/pf1/ammo-recovery/-/archive/1.1.1.3/ammo-recovery-1.1.1.3.zip",
"download": "https://gitlab.com/koboldworks/pf1/ammo-recovery/-/archive/1.2.0/ammo-recovery-1.2.0.zip",
"url": "https://gitlab.com/koboldworks/pf1/ammo-recovery",
"bugs": "https://gitlab.com/koboldworks/pf1/ammo-recovery/-/issues"
}
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment