Require Cabal 1.20 across the board, for consistency.

qtah-cpp requires it for BuildFlags.buildNumJobs, as noted in its .cabal file.
There's no point in having the minimum Cabal version differ for different parts
of Qtah.
parent 118979ae
......@@ -9,7 +9,7 @@ maintainer: Bryan Gardiner <bog@khumba.net>
copyright: Copyright 2015-2018 The Qtah Authors.
category: Graphics
build-type: Simple
cabal-version: >=1.10
cabal-version: 1.20
description:
Qtah is a set of Qt bindings for Haskell. This package contains example
programs to demonstrate use of the bindings.
......
......@@ -9,7 +9,7 @@ maintainer: Bryan Gardiner <bog@khumba.net>
copyright: Copyright 2015-2018 The Qtah Authors.
category: Graphics
build-type: Custom
cabal-version: >=1.10
cabal-version: 1.20
description:
Qtah is a set of Qt bindings for Haskell. This package is a Hoppy FFI
generator. You shouldn't need it directly; rather, qtah-cpp and qtah use it
......
......@@ -9,7 +9,7 @@ maintainer: Bryan Gardiner <bog@khumba.net>
copyright: Copyright 2015-2018 The Qtah Authors.
category: Graphics
build-type: Custom
cabal-version: >=1.10
cabal-version: 1.20
description:
Qtah is a set of Qt bindings for Haskell. This package contains the Haskell
side of the bindings, and is what Qt programs should use directly.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment