Commit 0cc5012d authored by Gianfranco Costamagna's avatar Gianfranco Costamagna Committed by Sophie Brun
Browse files

Import Debian changes 7.70+dfsg1-6

nmap (7.70+dfsg1-6) unstable; urgency=medium

  * Team upload
  * Drop 0004-library-versions.patch, it has been fixed differently
    by upstream, and it is now breaking Ubuntu builds.
parent 9da07021
nmap (7.70+dfsg1-6) unstable; urgency=medium
* Team upload
* Drop 0004-library-versions.patch, it has been fixed differently
by upstream, and it is now breaking Ubuntu builds.
-- Gianfranco Costamagna <locutusofborg@debian.org> Wed, 12 Dec 2018 15:58:18 +0100
nmap (7.70+dfsg1-5) unstable; urgency=medium
* d/control: zenmap: move polkit from Depends to Recommends, note
......
Description: Report correct versions for libssh2 and zlib
Do not report the versions from the libssh2/libssh2v.h and libz/libzv.h files,
because they are not correct when nmap is linked against the system version of
these (instead of the version bundled with nmap). Instead use the version
facility provided by the libraries themselves.
Origin: upstream
Bug: https://github.com/nmap/nmap/pull/957
---
nmap.cc | 12 ++++++++++--
1 file changed, 10 insertions(+), 2 deletions(-)
diff --git a/nmap.cc b/nmap.cc
index ec46267..6fc3e8f 100644
--- a/nmap.cc
+++ b/nmap.cc
@@ -182,11 +182,19 @@
#endif
#if HAVE_LIBSSH2
-#include <libssh2.h>
+#ifdef LIBSSH2_INCLUDED
+#include "libssh2/libssh2v.h"
+#else
+#include "libssh2.h"
+#endif
#endif
#if HAVE_LIBZ
-#include <zlib.h>
+#ifdef ZLIB_INCLUDED
+#include "libz/libzv.h"
+#else
+#include "zlib.h"
+#endif
#endif
/* To get the version number only. */
0001-use-su-to-root.patch
0002-Use-Debian-s-ca-certificates.patch
0003-Link-against-lua-lpeg.patch
0004-library-versions.patch
0005-ncat-manpage-self-reference.patch
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment