Commit b7e824db authored by Sophie Brun's avatar Sophie Brun

Bundle activerecord gem in beef to have a compatible version

parent feea9642
# BeEF's Gemfile
gem 'activerecord', '>= 6.0.0'
gem 'sqlite3'
source 'https://rubygems.org'
......@@ -10,3 +10,4 @@ debian/scripts/beef-xss-stop usr/bin/
extensions usr/share/beef-xss/
modules usr/share/beef-xss/
debian/set-new-pass.rb usr/share/beef-xss/
debian/bundle/ruby/2.5.0 var/lib/gems/
......@@ -10,6 +10,8 @@ override_dh_auto_build:
echo -n "DEPENDENCY CHECK":
bundle install --local --no-cache --without test --path debian/gems && echo "OK" || echo "NOT OK"
rm -rf debian/gems
#Install only the activerecord gem version 6.*: not currently in Debian but required fo this version.
bundle install --gemfile=debian/Gemfile --path bundle
override_dh_install:
dh_install --sourcedir=$$(pwd)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment