Commit 41ab1c9b authored by Sophie Brun's avatar Sophie Brun

Refresh patches

parent daf9aea5
......@@ -2,6 +2,7 @@ beef-xss (0.4.6.1-0kali1) kali-dev; urgency=medium
* Import new upstream release
* Add ruby-mime-types to depends and build-depends
* Refresh patches
-- Sophie Brun <sophie@freexian.com> Thu, 16 Jul 2015 08:53:48 +0200
......
......@@ -38,6 +38,6 @@ This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+require 'erubis'
+require 'dm-migrations'
+require 'msfrpc-client'
require 'mime/types'
# @note Include the filters
require 'core/filters'
......@@ -7,23 +7,23 @@ Last-Update: <2014-06-17>
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/Gemfile
+++ b/Gemfile
@@ -10,8 +10,8 @@ gem "eventmachine"
gem "thin"
gem "sinatra"
gem "rack"
-gem "em-websocket", "~> 0.3.6" # WebSocket support
-gem "uglifier", "~> 2.2.1"
+gem "em-websocket", ">= 0.3.6" # WebSocket support
+gem "uglifier", ">= 2.2.1"
@@ -10,8 +10,8 @@ gem 'eventmachine'
gem 'thin'
gem 'sinatra'
gem 'rack'
-gem 'em-websocket', '~> 0.3.6' # WebSocket support
-gem 'uglifier', '~> 2.2.1'
+gem 'em-websocket', '>= 0.3.6' # WebSocket support
+gem 'uglifier', '>= 2.2.1'
gem 'mime-types'
# Windows support
if RUBY_PLATFORM.downcase.include?("mswin") || RUBY_PLATFORM.downcase.include?("mingw")
@@ -20,7 +20,7 @@ if RUBY_PLATFORM.downcase.include?("mswi
gem "execjs"
gem "win32console"
elsif !RUBY_PLATFORM.downcase.include?("darwin")
- gem "therubyracer", "0.11.3"
+ gem "therubyracer", ">= 0.11.3"
gem "execjs"
@@ -22,7 +22,7 @@ if RUBY_PLATFORM.downcase.include?('mswi
gem 'execjs'
gem 'win32console'
elsif !RUBY_PLATFORM.downcase.include?('darwin')
- gem 'therubyracer', '0.11.3'
+ gem 'therubyracer', '>= 0.11.3'
gem 'execjs'
end
......@@ -8,7 +8,8 @@ overidde_dh_auto_clean:
override_dh_auto_build:
echo -n "DEPENDENCY CHECK":
bundle install --local --no-cache --without test && echo "OK" || echo "NOT OK"
bundle install --local --no-cache --without test --path debian/gems && echo "OK" || echo "NOT OK"
rm -rf debian/gems
override_dh_install:
dh_install --sourcedir=$$(pwd)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment