Commit 0657df6c authored by Sophie Brun's avatar Sophie Brun

Amend gemfile with correct versions

parent 8f639ee6
Description: Change specific versions in Gemfile
Author: Sophie Brun <sophie@freexian.com>
Origin: <upstream|backport|vendor|other>, <URL, required except if Author is present>
Bug: https://github.com/beefproject/beef/issues/1025
Reviewed-by: Raphaël Hertzog <raphael@freexian.com>
Last-Update: <2014-06-17>
......@@ -8,19 +7,31 @@ Last-Update: <2014-06-17>
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/Gemfile
+++ b/Gemfile
@@ -6,11 +6,11 @@
@@ -6,12 +6,13 @@
# See the file 'doc/COPYING' for copying permission
#
-gem "eventmachine", "1.0.3"
+gem "eventmachine"
+gem "eventmachine", ">= 1.0.3"
gem "thin"
-gem "sinatra", "1.4.2"
-gem "rack", "1.5.2"
-gem "em-websocket", "~> 0.3.6"
+gem "sinatra"
+gem "rack"
+gem "em-websocket"
gem "uglifier", "~> 2.2.1"
-gem "uglifier", "~> 2.2.1"
+gem "sinatra", ">= 1.4.2"
+gem "rack", ">= 1.4.1"
+gem "em-websocket", ">= 0.3.6" # WebSocket support
+gem "uglifier", ">= 2.2.1"
+# Windows support
if RUBY_PLATFORM.downcase.include?("mswin") || RUBY_PLATFORM.downcase.include?("mingw")
# make sure you install this gem following https://github.com/hiranpeiris/therubyracer_for_windows
gem "therubyracer", "~> 0.11.0beta1"
@@ -31,7 +32,7 @@ gem "parseconfig"
gem "erubis"
gem "dm-migrations"
gem "msfrpc-client"
-gem "rubyzip", "~> 1.0.0"
+gem "rubyzip", ">= 1.0.0"
# notifications
gem "twitter"
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment