Commit 8914d00e authored by Sophie Brun's avatar Sophie Brun

Imported Upstream version 1.3.1

parent e342bcca
# ChangeLog # ChangeLog
## 1.3.1 _(October 13, 2015)_
- `UI`
- `CLI`
- Options
- `--http-ssl-key` -- Fixed typo causing option to raise error.
## 1.3 _(October 01, 2015)_ ## 1.3 _(October 01, 2015)_
- `UI` - `UI`
......
...@@ -3,7 +3,7 @@ ...@@ -3,7 +3,7 @@
<table> <table>
<tr> <tr>
<th>Version</th> <th>Version</th>
<td>1.3</td> <td>1.3.1</td>
</tr> </tr>
<tr> <tr>
<th>Homepage</th> <th>Homepage</th>
......
...@@ -366,7 +366,7 @@ class OptionParser < UI::CLI::OptionParser ...@@ -366,7 +366,7 @@ class OptionParser < UI::CLI::OptionParser
end end
on( '--http-ssl-key PATH', 'SSL private key to use.' ) do |file| on( '--http-ssl-key PATH', 'SSL private key to use.' ) do |file|
options.http.ssl_key = file options.http.ssl_key_filepath = file
end end
on( "--http-ssl-key-type #{OptionGroups::HTTP::SSL_KEY_TYPES.join(',')}", on( "--http-ssl-key-type #{OptionGroups::HTTP::SSL_KEY_TYPES.join(',')}",
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment