Commit 73f4974a authored by Mati's avatar Mati

Imported Upstream version 1.2~svn2247

parent 7772bba6
...@@ -46,7 +46,10 @@ to compile and install the suite: ...@@ -46,7 +46,10 @@ to compile and install the suite:
* gcrypt: Use libgcrypt crypto library instead of the default OpenSSL. * gcrypt: Use libgcrypt crypto library instead of the default OpenSSL.
And also use internal fast sha1 implementation (borrowed from GIT) And also use internal fast sha1 implementation (borrowed from GIT)
* libnl: Add support for netlink (nl80211). * libnl: Add support for netlink (nl80211). Linux only. Requires libnl1 OR libnl3.
Dependencies (debian):
LibNL 1: libnl-dev
LibNL 3: libnl-3-dev and libnl-genl-3-dev.
Example: Example:
......
...@@ -74,7 +74,7 @@ else ifeq ($(libnl), true) ...@@ -74,7 +74,7 @@ else ifeq ($(libnl), true)
endif endif
ifeq ($(NLLIBNAME),) ifeq ($(NLLIBNAME),)
$(error Cannot find development files for any supported version of libnl. install either libnl1 or libnl3.) $(error Cannot find development files for any supported version of libnl. install either libnl1 or libnl3.)
endif endif
LIBS += $(shell $(PKG_CONFIG) --libs $(NLLIBNAME)) LIBS += $(shell $(PKG_CONFIG) --libs $(NLLIBNAME))
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment