Commit 85f5fc5a authored by Ivana Kellyerova's avatar Ivana Kellyerova

Update dependencies

- add support for Python 3.7
- remove requirements.txt
- add dependency versions to setup.py
- remove Sphinx as main dependency; move to extras_required instead
parent f6214986
Pipeline #37838512 passed with stages
in 2 minutes and 16 seconds
python 3.7:
stage: test
image: python:3.7
script:
- python --version
- ./setup.py install
- ./setup.py test -v
python 3.6:
stage: test
image: python:3.6
script:
- python --version
- pip install -r requirements.txt
- ./setup.py install
- ./setup.py test -v
......@@ -12,7 +19,6 @@ python 3.5:
image: python:3.5
script:
- python --version
- pip install -r requirements.txt
- ./setup.py install
- ./setup.py test -v
......@@ -21,16 +27,15 @@ python 3.4:
image: python:3.4
script:
- python --version
- pip install -r requirements.txt
- ./setup.py install
- ./setup.py test -v
pages:
stage: deploy
image: python:3.6
image: python:3.7
script:
- pip install -r requirements.txt
- ./setup.py install
- pip install -e .[docs]
- ./setup.py build_sphinx
- mkdir public
- mv build/sphinx/html/* public/
......
# WIP (unreleased)
- Explicitly support Python 3.7+
- Remove Sphinx as dependency
- Remove requirements.txt and add dependency versions to setup.py
# v2.0
_June 24, 2018_
......
......@@ -26,7 +26,7 @@ First, get the latest version of the source code from GitLab:
$ git clone git@gitlab.com:jenx/rectify.git
Create and activate a virtual environment to keep *rectify* and its
dependencies separate from system-wide packages:
dependencies separate from system packages:
.. code-block:: sh
......@@ -34,11 +34,10 @@ dependencies separate from system-wide packages:
$ python3 -m venv rectify.env
$ source rectify.env/bin/activate
Install *rectify*'s prerequisites and then *rectify* itself:
Install *rectify*:
.. code-block:: sh
$ pip install -r requirements.txt
$ python setup.py install
You are good to go! You can test whether the setup works by importing
......
......@@ -36,16 +36,21 @@ setup(
'Programming Language :: Python :: 3.4',
'Programming Language :: Python :: 3.5',
'Programming Language :: Python :: 3.6',
'Programming Language :: Python :: 3.7',
'Programming Language :: Python :: 3 :: Only',
'Topic :: Artistic Software',
'Topic :: Multimedia :: Graphics',
],
install_requires=[
'docopt',
'Pillow',
'sphinx',
'sphinxcontrib-napoleon',
'docopt>=0.6.2',
'Pillow>=5.3.0',
],
extras_require={
'docs': [
'sphinx',
'sphinxcontrib-napoleon',
],
},
test_suite='tests',
entry_points={
'console_scripts': [
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment