Verified Commit 6777c36c authored by ita1024's avatar ita1024

Docs

parent ebc8485f
Semantik 1.0.1
--------------
* Fix improper pdf document dimensions
* Added installation notes for Fedora
* Fix the configuration and build on FreeBSD
* Add installation notes for Fedora
Semantik 1.0.0
--------------
......
......@@ -9,12 +9,12 @@ Source code: https://github.com/ita1024/semantik
The main dependencies are Qt Webengine, KDE 5 and Python 3. Here are
a few examples for typical setups:
Ubuntu: apt install libkf5kdelibs4support-dev libqt5svg5-dev qtwebengine5-dev qtpositioning5-dev python3-dev kio-dev
Ubuntu 17.10: apt install libkf5kdelibs4support-dev libqt5svg5-dev qtwebengine5-dev qtpositioning5-dev python3-dev kio-dev
Gentoo: emerge --ask kde-frameworks/kdelibs4support dev-qt/qtwebengine
Suse: zypper install python3-devel kio-devel kiconthemes-devel ki18n-devel kdelibs4support-devel
Fedora: dnf install python3-devel kf5-kio-devel kf5-kdelibs4support-devel kf5-ki18n-devel kf5-kiconthemes-devel
Fedora 27: dnf install python3-devel kf5-kio-devel kf5-kdelibs4support-devel kf5-ki18n-devel kf5-kiconthemes-devel
gcc-c++ qt5-linguist qt5-qtsvg-devel qt5-qtwebengine-devel
FreeBSD: pkg add qt5-svg python36 qt5-webengine kf5-kio kf5-kdelibs4support kf5-ki18n kf5-kiconthemes
FreeBSD 11: pkg add qt5-svg python36 qt5-webengine kf5-kio kf5-kdelibs4support kf5-ki18n kf5-kiconthemes
To build the project, run:
./waf configure build
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment