Commit 8aa5c316 authored by Mauricio's avatar Mauricio

Update requirements to work with recent versions of keops/pytorch

parent 0075d7df
Pipeline #161147723 failed with stages
in 1 minute and 6 seconds
# *************** Deformetrica requirements for installation ***************
# ***** Requirements with Version Specifiers *****
# See https://www.python.org/dev/peps/pep-0440/#version-specifiers
numpy >= 1.16.2
scikit-learn >= 0.20.3
matplotlib >= 2.2.2
nibabel >= 2.3.3
pillow >= 5.4.1
torch == 1.4
torchvision == 0.5
psutil >= 5.4.8
vtk >= 8.2.0
pykeops == 1.4
PyQt5
......@@ -71,9 +71,7 @@ def build_deformetrica():
'Topic :: Software Development :: Libraries'
],
install_requires=[
'pykeops==1.0.1',
'gputil>=1.3',
# 'PyQt5>=5.11',
'pykeops==1.4'
],
extra_link_args=['-Wl,-headerpad_max_install_names']
)
......@@ -115,8 +113,7 @@ def build_deformetrica_nox():
'Topic :: Software Development :: Libraries'
],
install_requires=[
'pykeops==1.0.1',
'gputil>=1.3',
'pykeops==1.4'
],
extra_link_args=['-Wl,-headerpad_max_install_names']
)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment