Commit db4069fd authored by David Sveningsson's avatar David Sveningsson

fix(elements): mark contextmenu attribute as deprecated

only works in firefox and living standard marked it obsolete.
parent b53959f5
......@@ -5967,7 +5967,7 @@ exports[`HTML elements <xmp> valid markup 1`] = `Array []`;
exports[`HTML elements global attributes invalid markup 1`] = `
Array [
Object {
"errorCount": 8,
"errorCount": 9,
"filePath": "test-files/elements/global-attributes-invalid.html",
"messages": Array [
Object {
......@@ -6112,6 +6112,16 @@ Array [
"severity": 2,
"size": 6,
},
Object {
"column": 4,
"context": undefined,
"line": 9,
"message": "Attribute \\"contextmenu\\" is deprecated on <p> element",
"offset": 190,
"ruleId": "no-deprecated-attr",
"severity": 2,
"size": 11,
},
],
"source": "<p contenteditable=\\"foobar\\"></p>
<p dir=\\"\\"></p>
......@@ -6121,6 +6131,7 @@ Array [
<p hidden=\\"foobar\\"></p>
<p tabindex=\\"\\"></p>
<p tabindex=\\"foobar\\"></p>
<p contextmenu=\\"foobar\\"></p>
",
"warningCount": 0,
},
......
......@@ -6,7 +6,8 @@
"draggable": ["true", "false"],
"hidden": [],
"tabindex": ["/-?\\d+/"]
}
},
"deprecatedAttributes": ["contextmenu"]
},
"a": {
......
......@@ -6,3 +6,4 @@
<p hidden="foobar"></p>
<p tabindex=""></p>
<p tabindex="foobar"></p>
<p contextmenu="foobar"></p>
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment