Commit 6c9482bd authored by h2b's avatar h2b

Backwards compatibility fix done for Scala 2.11.

parent 59e7e38b
......@@ -28,7 +28,7 @@ import scala.concurrent.Future
trait FutureTracking {
@volatile
protected var future = Future.unit
protected var future = Future.successful(()) //Future.unit apparently requires 2.12
/**
* Indicates whether some concurrent operation is done.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment