Commit 87055e73 authored by Gary E. Miller's avatar Gary E. Miller 💬

Change Version to 3.21 for release. But not yet a release.

parent c68d3d2c
GPSD project news
3.20.1~dev: In process
3.21: 2020-08-04
Create python programs from .in files to allow macro substitution.
Finally clean .sconsign*.dblite with "scons -c"
Remove revision.h. Move REVISION into gpsd_config.h
......@@ -13,7 +13,8 @@
Add icondir and sharedir install options
Install basic doc in sharedir
Move gps_data_t->status to gps_fix_t.status for better fix merging
The gps python module is now pure python. Manually delete any old packet*so.
The gps python module is now Pure Python + FFI. FFI only for packet.py
User should manually delete any old packet*so.
Add wspeedt, wspeedr, wanglem, wanglet, wangler to gps_fix_t
Add "-p CONFIG", "-p STATUS", "-t" and "-tt" options to ubxtool.
Add python_shebang option to scons config.
......
......@@ -238,7 +238,7 @@ icon_files = [
# name from the version, or separates version components.
#
# package version
gpsd_version = "3.20.1~dev"
gpsd_version = "3.21"
if 'dev' in gpsd_version:
(st, gpsd_revision) = _getstatusoutput('git describe --tags')
if st != 0:
......
......@@ -7,7 +7,7 @@
*/
// Keep next 4 in sync with SConstruct
#define VERSION "3.20.1~dev"
#define VERSION "3.21"
#define REVISION VERSION
#define GPSD_PROTO_VERSION_MAJOR 3
#define GPSD_PROTO_VERSION_MINOR 15
......
......@@ -78,7 +78,7 @@ extern "C" {
* change tsip.superpkt from bool to int.
* Add tsip .machine_id, .hardware_code, .last_tow, last_chan_seen
* Split gps_device_t.subtype into subtype and subtype1
* 3.20.1
* 3.21
* GPSD_PROTO_*_VERSION moved to gpsd_config.h
* Add gps_context_t.passive
* Add gps_context_t.batteryRTC
......
......@@ -23,7 +23,7 @@ into more detail about the steps.
which to use yet if you have easy access to both, but knowing which
alternatives are readily available to you is a good place to start.
. Verify that your gpsd version is at least 3.20. Many problems are
. Verify that your gpsd version is at least 3.21. Many problems are
caused by the use of old versions. When in doubt, reinstall
gpsd from the upstream source. Many distributions ship old
and/or broken versions of gpsd.
......
......@@ -6,7 +6,7 @@ Blursday 86 March 2020
== WARNING
This document assumes you are using gpsd versions 3.20 or git
This document assumes you are using gpsd versions 3.21 or git
head. Using older versions will fail in strange ways.
== Introduction
......@@ -74,8 +74,8 @@ out.
== Requirements
This document assumes that you have installed gpsd version 3.19 or 3.20, basic
knowledge of how to use _gpsd_. Before continuing you should know how
This document assumes that you have installed gpsd version 3.21 or later,
basic knowledge of how to use _gpsd_. Before continuing you should know how
to start and stop _gpsd_, and how to use _cgps_ to see you current
position and fix status.
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment