• Ævar Arnfjörð Bjarmason's avatar
    gitweb: hard-depend on the Digest::MD5 5.8 module · 7d5b30e0
    Ævar Arnfjörð Bjarmason authored
    Since my d48b2841 ("perl: bump the required Perl version to 5.8 from
    5.6.[21]", 2010-09-24), we've depended on 5.8, so there's no reason to
    conditionally require Digest::MD5 anymore. It was released with perl
    v5.7.3[1]
    
    The initial introduction of the dependency in
    e9fdd74e ("gitweb: (gr)avatar support", 2009-06-30) says as much,
    this also undoes part of the later 2e9c8789 ("gitweb: Mention
    optional Perl modules in INSTALL", 2011-02-04) since gitweb will
    always be run on at least 5.8, so there's no need to mention
    Digest::MD5 as a required module in the documentation, let's instead
    say that we require perl 5.8.
    
    1. $ corelist Digest::MD5
       Data for 2015-02-14
       Digest::MD5 was first released with perl v5.7.3
    Signed-off-by: Ævar Arnfjörð Bjarmason's avatarÆvar Arnfjörð Bjarmason <avarab@gmail.com>
    Signed-off-by: default avatarJunio C Hamano <gitster@pobox.com>
    7d5b30e0
INSTALL 14.3 KB