Commit 7928522f authored by Fabien Catteau's avatar Fabien Catteau

Merge branch 'eread/update-project-to-golang-1_15_5' into 'main'

Update project to Go 1.15.5

See merge request !18
parents d1994129 bdb8e417
Pipeline #240951325 failed with stages
in 99 minutes and 14 seconds
......@@ -11,12 +11,11 @@
- pkg/
exclude:
- pkg/*.json
expire_in: 1 day
when: on_success
cache:
key: ${CI_JOB_NAME}
paths:
- tmp/omnibus/cache
- tmp/omnibus/cache
asdf-0.7.8:
extends: .deb
......@@ -34,11 +33,11 @@ license_management:
variables:
OMNIBUS_PROJECT: license_management
golang-1.15.2:
golang-1.15.5:
extends: .deb
variables:
OMNIBUS_PROJECT: golang
GOLANG_VERSION: '1.15.2'
GOLANG_VERSION: '1.15.5'
java-8:
extends: .deb
......
# GitLab License management changelog
## v3.28.4
- Set `asdf` configuration to use Go `1.15.5` by default. (!18)
- Fix test by rolling expected version of `cli` forward to `6.14.9`. (!18)
## v3.28.3
- Stream `npm ci` output to log. (https://gitlab.com/gitlab-org/security-products/analyzers/license-finder/-/merge_requests/16)
......
......@@ -8,7 +8,7 @@ GIT
PATH
remote: .
specs:
license-management (3.28.3)
license-management (3.28.4)
license_finder (~> 6.7)
spandx (~> 0.13)
......
dotnet-core 3.1.302
elixir 1.10.4
golang 1.15.2
golang 1.15.5
java 8
mono 6.8.0.123
nodejs 12.18.2
......
# frozen_string_literal: true
golang_version = ENV.fetch('GOLANG_VERSION', '1.15.2')
golang_version = ENV.fetch('GOLANG_VERSION', '1.15.5')
name "golang-#{golang_version}"
maintainer "GitLab B.V."
......
# frozen_string_literal: true
name "asdf_golang"
default_version "1.15.2"
default_version "1.15.5"
source url: "https://golang.org/dl/go#{version}.linux-amd64.tar.gz"
relative_path "go"
......@@ -21,6 +21,9 @@ end
version "1.15.2" do
source sha256: "b49fda1ca29a1946d6bb2a5a6982cf07ccd2aba849289508ee0f9918f6bb4552"
end
version "1.15.5" do
source sha256: "9a58494e8da722c3aef248c9227b0e9c528c7318309827780f16220998180a0d"
end
build do
mkdir install_dir
......
......@@ -2,6 +2,6 @@
module License
module Management
VERSION = '3.28.3'
VERSION = '3.28.4'
end
end
......@@ -35,7 +35,7 @@
"dependencies": [
{
"name": "cli",
"version": "6.14.8",
"version": "6.14.9",
"package_manager": "bower",
"path": "bower.json",
"licenses": [
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment