Commit c7a3d759 authored by Robert Speicher's avatar Robert Speicher 🌴 Committed by Robert Speicher

Merge branch 'git-2-7-3' into 'master'

Bump Git version requirement to 2.7.3

[ci skip]

See merge request !3240
parent 0424e72d
Pipeline #785529 skipped
......@@ -17,6 +17,9 @@ v 8.6.0 (unreleased)
- Add main language of a project in the list of projects (Tiago Botelho)
- Add ability to show archived projects on dashboard, explore and group pages
v 8.5.7
- Bump Git version requirement to 2.7.3
v 8.5.6
- Obtain a lease before querying LDAP
......
......@@ -68,7 +68,7 @@ GitLab is a Ruby on Rails application that runs on the following software:
- Ubuntu/Debian/CentOS/RHEL
- Ruby (MRI) 2.1
- Git 1.7.10+
- Git 2.7.3+
- Redis 2.8+
- MySQL or PostgreSQL
......
......@@ -76,7 +76,7 @@ Make sure you have the right version of Git installed
# Install Git
sudo apt-get install -y git-core
# Make sure Git is version 1.7.10 or higher, for example 1.7.12 or 2.0.0
# Make sure Git is version 2.7.3 or higher
git --version
Is the system packaged Git too old? Remove it and compile from source.
......
......@@ -911,7 +911,7 @@ namespace :gitlab do
end
def check_git_version
required_version = Gitlab::VersionInfo.new(1, 7, 10)
required_version = Gitlab::VersionInfo.new(2, 7, 3)
current_version = Gitlab::VersionInfo.parse(run(%W(#{Gitlab.config.git.bin_path} --version)))
puts "Your git bin path is \"#{Gitlab.config.git.bin_path}\""
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment