Commit fb8e9509 authored by Dmitriy Zaporozhets's avatar Dmitriy Zaporozhets

Merge branch 'bump-ingress-chart-112' into 'master'

Bump nginx-ingress chart to 1.1.2

See merge request !24203
parents df7fe637 8fb86a73
Pipeline #43253777 passed with stages
in 48 minutes and 35 seconds
......@@ -3,7 +3,7 @@
module Clusters
module Applications
class Ingress < ActiveRecord::Base
VERSION = '0.23.0'.freeze
VERSION = '1.1.2'.freeze
self.table_name = 'clusters_applications_ingress'
......
---
title: Bump nginx-ingress chart to 1.1.2
merge_request: 24203
author:
type: other
......@@ -35,7 +35,7 @@ describe Clusters::Applications::Ingress do
let(:application) { create(:clusters_applications_ingress, :scheduled, version: '0.22.0') }
it 'updates the application version' do
expect(application.reload.version).to eq('0.23.0')
expect(application.reload.version).to eq('1.1.2')
end
end
end
......@@ -90,7 +90,7 @@ describe Clusters::Applications::Ingress do
it 'should be initialized with ingress arguments' do
expect(subject.name).to eq('ingress')
expect(subject.chart).to eq('stable/nginx-ingress')
expect(subject.version).to eq('0.23.0')
expect(subject.version).to eq('1.1.2')
expect(subject).to be_rbac
expect(subject.files).to eq(ingress.files)
end
......@@ -107,7 +107,7 @@ describe Clusters::Applications::Ingress do
let(:ingress) { create(:clusters_applications_ingress, :errored, version: 'nginx') }
it 'should be initialized with the locked version' do
expect(subject.version).to eq('0.23.0')
expect(subject.version).to eq('1.1.2')
end
end
end
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment