Commit da319587 authored by Mike Greiling's avatar Mike Greiling

Merge branch '54065-bump-minimum-node-version-to-8' into 'master'

Bump minimal node version from 6 to 8.10.0

Closes #54065

See merge request !24305
parents 763c9ddb 24e2e722
Pipeline #43287963 passed with stages
in 33 minutes and 3 seconds
...@@ -804,10 +804,6 @@ qa:selectors: ...@@ -804,10 +804,6 @@ qa:selectors:
- yarn run webpack-prod - yarn run webpack-prod
<<: *except-docs <<: *except-docs
qa-frontend-node:6:
<<: *qa-frontend-node
image: node:6-alpine
qa-frontend-node:8: qa-frontend-node:8:
<<: *qa-frontend-node <<: *qa-frontend-node
image: node:8-alpine image: node:8-alpine
......
...@@ -21,8 +21,8 @@ We also use [Axios][axios] to handle all of our network requests. ...@@ -21,8 +21,8 @@ We also use [Axios][axios] to handle all of our network requests.
We also utilize [webpack][webpack] to handle the bundling, minification, and We also utilize [webpack][webpack] to handle the bundling, minification, and
compression of our assets. compression of our assets.
Working with our frontend assets requires Node (v6.0 or greater) and Yarn Working with our frontend assets requires Node (v8.10.0 or greater) and Yarn
(v1.2 or greater). You can find information on how to install these on our (v1.10.0 or greater). You can find information on how to install these on our
[installation guide][install]. [installation guide][install].
### Browser Support ### Browser Support
......
This diff is collapsed.
...@@ -163,6 +163,7 @@ ...@@ -163,6 +163,7 @@
"yarn-deduplicate": "^1.0.5" "yarn-deduplicate": "^1.0.5"
}, },
"engines": { "engines": {
"node": ">=8.10.0",
"yarn": "^1.10.0" "yarn": "^1.10.0"
} }
} }
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment