Commit b5ea6aa1 authored by Sytse Sijbrandij's avatar Sytse Sijbrandij

Ensure customers know that GitLab.com supports RHEL.

parent 4525fc84
# Operating Systems
## Linux
GitLab is developed for the Linux operating system.
GitLab officially supports (recent versions of) these Linux distributions:
## GitLab officially supports
- Ubuntu Linux
- Debian/GNU Linux
It should also work on (though they are not officially supported):
## GitLab.com offers paid support for
- Arch
- Red Hat Enterprise Linux (RHEL)
- CentOS
- Oracle Linux
## Not officially supported
- Arch Linux
- Fedora
- Gentoo
- RHEL
## Other Unix Systems
On the above distributions it is pretty easy to install GitLab yourself.
## Unsupported Unix Systems
There is nothing that prevents GitLab from running on other Unix operating
systems. This means you may get it to work on systems running FreeBSD or OS X.
**If you want to try, please proceed with caution!**
There is nothing that prevents GitLab from running on other Unix operating systems.
This means you may get it to work on systems running FreeBSD or OS X.
If you want to do this, please be aware it could be a lot of work.
Please consider using a virtual machine to run GitLab.
## Windows
## Other operating systems such as Windows
GitLab does **not** run on Windows and we have no plans of supporting it in the
near future. Please consider using a virtual machine to run GitLab.
GitLab does **not** run on Windows and we have no plans of supporting it in the near future.
Please consider using a virtual machine to run GitLab.
# Rubies
# Ruby versions
GitLab requires Ruby (MRI) 1.9.3 and several Gems with native components.
While it is generally possible to use other Rubies (like
[JRuby](http://jruby.org/) or [Rubinius](http://rubini.us/)) it might require
some work on your part.
GitLab requires Ruby (MRI) 1.9.3 or 2.0+.
While it is generally possible to use other Rubies
(like [JRuby](http://jruby.org/) or [Rubinius](http://rubini.us/))
it might require some work since GitLab uses several Gems that have native extensions.
# Hardware requirements
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment