Commit ff323ecd authored by Hossein Pursultani's avatar Hossein Pursultani

Fix minor typos

parent 87598189
Pipeline #63855240 failed with stages
in 15 minutes and 55 seconds
#!/bin/bash
_CRD_NAME='{{ template "gitlab.operator.crdName" . }}'
createCRD() {
......@@ -5,7 +7,7 @@ createCRD() {
printf 'Waiting for CRD `%s` to become available ...\n' "$_CRD_NAME"
_cnt=0
_max=10 # roughly 10ms
_max=10 # roughly 10s
while [ $_cnt -lt $_max ]; do
_out="$( kubectl get crd $_CRD_NAME 2>&1 )"
[ "$?" = "0" ] && {
......
......@@ -12,7 +12,7 @@ We provide the flag `global.operator.enabled`, when set to true it enables the o
## Installing using the operator
The operator makes use of Kubernetes CustomResourceDefinitions (CRD). Therefor, you need cluster level privilege to install
The operator makes use of Kubernetes CustomResourceDefinitions (CRD). Therefore, you need cluster level privilege to install
it. Please note that this privilege is only required for CRD installation. The operator itself does not mandate it.
Simply run `helm upgrade --install <release-name> . --set global.operator.enabled=true ... ` where `...` shall be replaced by the rest of the values you would like to set. Along with everything else, this command will install the CRD, GitLab custom resource, and the operator.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment