Commit 1dd646f1 authored by Robert Speicher's avatar Robert Speicher

Blow up the old site 💥

parent 0f1b0f4a

Too many changes to show.

To preserve performance only 1000 of 1000+ files are displayed.

; This file is for unifying the coding style for different editors and IDEs.
; More information at http://EditorConfig.org
root = true
; Use 2 spaces for indentation in all Ruby files
[*.rb]
indent_style = space
indent_size = 2
[Rakefile]
indent_style = space
indent_size = 2
[Gemfile*]
indent_style = space
indent_size = 2
[config.ru]
indent_style = space
indent_size = 2
* text=auto
*.md text eol=lf
.bundle
.DS_Store
.sass-cache
.gist-cache
.pygments-cache
.preview-mode
recurly/config.yml
_deploy
public
sass.old
source.old
source/_stash
source/stylesheets/screen.css
vendor
node_modules
.idea
*~
test:
script:
- pwd
- git rev-parse HEAD
- export LC_ALL=en_US.UTF-8
- ''
- bundle install --path ~/bundle
- ''
- bundle exec yaml-lint source/_data/*.yml
- ''
- "# build without deploying, so that we know if a MR is horribly broken"
- bundle exec rake build
tags:
except:
- tags
deploy:
script:
- pwd
- export LC_ALL=en_US.UTF-8
- ''
- bundle install --path ~/bundle
- bundle exec rake build
- rsync -r --delete-after public/ ~/public/
type: deploy
tags:
only:
- master
except:
- tags
if [ -f "$rvm_path/scripts/rvm" ] && [ -f ".rvmrc" ] ; then
source "$rvm_path/scripts/rvm"
source ".rvmrc"
fi
\ No newline at end of file
plugins
sass
source
language: ruby
rvm:
- 2.0.0
- 1.9.3
script: bundle exec rake install; bundle exec rake generate
# Octopress Changelog
## 2.0
- Now based on [mojombo/jekyll](http://github.com/mojombo/jekyll)
- Sports a semantic HTML5 template
- Easy theming with Compass and Sass
- A Mobile friendly responsive (320 and up) layout
- Built in 3rd party support for Twitter, Google Plus One, Disqus Comments, Pinboard, Delicious, and Google Analytics
- Deploy to Github pages or use Rsync
- Built in support for POW and Rack servers
- Beautiful [Solarized](http://ethanschoonover.com/solarized) syntax highlighting
- Super easy setup and configuration
**New Plugins, Filters, & Generators**
- **Gist Tag** for easily embedding gists in your posts
- **Pygments Cache** makes subsequent compiling much faster
- **Include Code Tag** lets you embed external code snippets from your file system and adds a download link
- **Pullquote Tag** Generate beautiful semantic pullquotes (no double data) based on Maykel Loomans's [technique](http://miekd.com/articles/pull-quotes-with-html5-and-css/)
- **Blockquote Tag** makes it easy to semantically format blockquotes
- **Category Generator** gives you archive pages for each category
- **Sitemap.xml Generator** for search engines
## 1.0
- **No longer supported.**
- Jekyll Matured, but Henrik's Jekyll fork did not.
- Thanks for all your pull requests, I learned a lot.
You can help to improve the [about.gitlab.com](https://about.gitlab.com/) website by sending merge requests to this repository.
Thank you for your interest and help!
We don't mind people inside and outside the company making suggestions to change significant things.
Feel free to make a proposal, we can discuss anything and if we don't agree we'll feel free not to merge it and thank you for caring about it.
By submitting code as an individual you agree to the [individual contributor license agreement](doc/legal/individual_contributor_license_agreement.md).
By submitting code as an entity you agree to the [corporate contributor license agreement](doc/legal/corporate_contributor_license_agreement.md).
source "https://rubygems.org"
group :development do
gem 'rake', '~> 10.0'
gem 'jekyll', '2.4'
gem 'octopress-hooks', '~> 2.2'
gem 'octopress-date-format', '~> 2.0'
gem 'jekyll-sitemap'
gem 'rdiscount', '~> 2.0'
gem 'RedCloth', '~> 4.2.9'
gem 'haml', '~> 4.0'
gem 'compass', '~> 1.0.1'
gem 'sass-globbing', '~> 1.0.0'
gem 'rb-fsevent', '~> 0.9'
gem 'stringex', '~> 1.4.0'
end
group :test do
gem 'html-proofer'
gem 'yaml-lint'
end
gem 'sinatra', '~> 1.4.2'
gem 'yui-compressor', '~> 0.12.0'
gem 'html_compressor', '~> 0.0.3'
gem "sinatra-contrib", "~> 1.4.2"
gem 'redcarpet'
gem 'recurly', '~> 2.2.1'
gem "daemons", "~> 1.1.9"
gem 'therubyracer'
gem 'oga'
gem 'httparty'
GEM
remote: https://rubygems.org/
specs:
POpen4 (0.1.4)
Platform (>= 0.4.0)
open4
Platform (0.4.0)
RedCloth (4.2.9)
addressable (2.3.8)
ansi (1.5.0)
ast (2.2.0)
backports (3.6.4)
blankslate (2.1.2.4)
celluloid (0.16.0)
timers (~> 4.0.0)
chunky_png (1.3.4)
classifier-reborn (2.0.3)
fast-stemmer (~> 1.0)
coffee-script (2.4.1)
coffee-script-source
execjs
coffee-script-source (1.9.1.1)
colorator (0.1)
colored (1.2)
compass (1.0.3)
chunky_png (~> 1.2)
compass-core (~> 1.0.2)
compass-import-once (~> 1.0.5)
rb-fsevent (>= 0.9.3)
rb-inotify (>= 0.9)
sass (>= 3.3.13, < 3.5)
compass-core (1.0.3)
multi_json (~> 1.0)
sass (>= 3.3.0, < 3.5)
compass-import-once (1.0.5)
sass (>= 3.2, < 3.5)
daemons (1.1.9)
ethon (0.7.3)
ffi (>= 1.3.0)
execjs (2.5.2)
fast-stemmer (1.0.2)
ffi (1.9.8)
haml (4.0.6)
tilt
hitimes (1.2.2)
html-proofer (2.2.0)
addressable (~> 2.3)
colored (~> 1.2)
mercenary (~> 0.3.2)
nokogiri (~> 1.5)
parallel (~> 1.3)
typhoeus (~> 0.7)
yell (~> 2.0)
html_compressor (0.0.3)
POpen4 (>= 0.1.4)
httparty (0.13.7)