Commit 536709f6 authored by gerd's avatar gerd

fix cgi


git-svn-id: https://godirepo.camlcity.org/svn/wdialog/[email protected] f54c9a64-0731-4a92-b797-30fd5898f27c
parent 9f8bdd65
......@@ -49,7 +49,7 @@ libdir=`ocamlc -where`/wdialog
perl_libdir=/usr/local/libexec/wdialog
# Packages to include anyway: (extended later)
requires="pxp-engine netstring unix pcre cgi"
requires="pxp-engine netstring unix pcre netcgi2"
libs_cma="unix.cma pcre.cma netstring.cma netcgi.cma pxp_engine.cma"
# For the META file of wdialog only:
......@@ -379,18 +379,9 @@ fi
# Check that cgi is available (and the right version):
if true; then
printf "%s" "Checking for cgi... "
if check_library cgi netcgi_types.mli; then
printf "%s" "Checking for netcgi2... "
if check_library netcgi2 netcgi.mli; then
echo "found"
printf "%s" "Checking whether cgi version >= 0.92... "
if check_library_version cgi '(0\.9[2-9]+)|([1-9].+)' netcgi_jserv_app.mli; then
echo "good"
else
echo "Your cgi version seems to be too old."
echo "You need at least cgi 0.92 (contained in ocamlnet-0.92), available from"
echo "http://sourceforge.net/projects/ocamlnet"
exit 1
fi
else
echo "not found"
echo "Sorry, installation is not possible without cgi."
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment