Skip to content
Snippets Groups Projects
Unverified Commit f1ad1f78 authored by Muhammad Moinur Rahman's avatar Muhammad Moinur Rahman
Browse files

x11-wm/jewel: Remove expired port

2024-01-19 x11-wm/jewel: Last upstream release was in 2004
parent 208ae563
No related branches found
No related tags found
No related merge requests found
Showing
with 1 addition and 430 deletions
......@@ -2962,3 +2962,4 @@ x11-wm/lwm||2024-01-18|Has expired: Last upstream release was in 2016
x11-wm/ratmen||2024-01-18|Has expired: Last upstream release was in 2008
x11-wm/larswm||2024-01-18|Has expired: Last upstream release was in 2010
x11-wm/flwm||2024-01-19|Has expired: Last upstream release and activity was in 2015
x11-wm/jewel||2024-01-19|Has expired: Last upstream release was in 2004
......@@ -53,7 +53,6 @@
SUBDIR += i3
SUBDIR += icewm
SUBDIR += ittywm
SUBDIR += jewel
SUBDIR += jwm
SUBDIR += kickshaw
SUBDIR += korgwm
......
PORTNAME= jewel
PORTVERSION= 0.12.41
PORTREVISION= 4
CATEGORIES= x11-wm
MASTER_SITES= http://mjr.towers.org.uk/comp/
MAINTAINER= ports@FreeBSD.org
COMMENT= Window manager based on aewm++
WWW= https://mjr.towers.org.uk/xwinman.html #jewel
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/LICENSE
DEPRECATED= Last upstream release was in 2004
EXPIRATION_DATE= 2024-01-19
USES= compiler gmake xorg
USE_CXXSTD= c++14
USE_XORG= x11 xext xpm
MAKE_ARGS= CFLAGS="${CXXFLAGS}"
ALL_TARGET= all
CXXFLAGS+= ${CXXFLAGS_${CHOSEN_COMPILER_TYPE}}
CXXFLAGS_clang= -Wno-c++11-narrowing
PORTDOCS= Changelog Changelog.DLR Changelog.jewel INSTALL README
OPTIONS_DEFINE= DOCS
post-patch:
@${FIND} ${WRKSRC} -name Makefile | ${XARGS} \
${REINPLACE_CMD} -i '' -e 's|g++|${CXX}|g; s|gcc|${CC}|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/jewel ${STAGEDIR}${PREFIX}/bin/jewel
${INSTALL_PROGRAM} ${WRKSRC}/goodies/appbar/appbar ${STAGEDIR}${PREFIX}/bin/jewel-appbar
${INSTALL_PROGRAM} ${WRKSRC}/goodies/fspanel/fspanel ${STAGEDIR}${PREFIX}/bin/jewel-fspanel
${INSTALL_PROGRAM} ${WRKSRC}/goodies/setrootimage/setrootimage ${STAGEDIR}${PREFIX}/bin/jewel-setrootimage
${INSTALL_PROGRAM} ${WRKSRC}/goodies/xsession/xsession ${STAGEDIR}${PREFIX}/bin/jewel-xsession
${INSTALL_MAN} ${WRKSRC}/jewel.1x ${STAGEDIR}${PREFIX}/man/man1
do-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for ii in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${ii} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>
SHA256 (jewel-0.12.41.tar.gz) = b931d64c7eaba12f0e54952962d95e8af853b362cb000d95f4c6414a8f0817b4
SIZE (jewel-0.12.41.tar.gz) = 122253
--- Makefile.orig 2005-01-03 21:54:59 UTC
+++ Makefile
@@ -12,7 +12,7 @@ CFLAGS = -g -O2 -Wall
CC = g++
CFLAGS = -g -O2 -Wall
-export prefix = /usr/X11R6
+export prefix = ${PREFIX}
export XROOT = $(prefix)
DESTDIR =
INCLUDES = -I$(XROOT)/include
@@ -51,7 +51,7 @@ $(SUBDIRS):
$(CC) $(OBJS) $(LDPATH) $(LIBS) -o $@
$(SUBDIRS):
- cd $@ && $(MAKE) $(MAKEFLAGS) $(MAKECMDGOALS)
+ cd $@ && $(MAKE) $(MAKECMDGOALS)
$(OBJS): %.o: %.cc $(HEADERS)
$(CC) $(CFLAGS) $(DEFINES) $(INCLUDES) -c $< -o $@
--- basemenu.hh.orig 2005-01-03 21:54:59 UTC
+++ basemenu.hh
@@ -24,6 +24,8 @@
#ifndef _BASEMENU_HH_
#define _BASEMENU_HH_
+using namespace std;
+
// Parts below borrowed from fspanel.c
static unsigned short cols[] = {
0xd75c, 0xd75c, 0xd75c, /* 0. light gray */
--- goodies/appbar/icon.cc.orig 2005-01-03 21:54:58 UTC
+++ goodies/appbar/icon.cc
@@ -35,7 +35,7 @@
#include "icon.hh"
-char * default_icon_xpm[] = {
+const char * default_icon_xpm[] = {
"16 16 16 1",
" c None",
". c #323232",
@@ -101,7 +101,7 @@ Icon::Icon(Display *d, Window parent)
if(! XpmCreatePixmapFromData(dpy,
icon_win,
- default_icon_xpm,
+ (char **)default_icon_xpm,
&icon_pixmap,
&icon_pixmap_mask,
&icon_pixmap_attr)==XpmSuccess)
@@ -165,7 +165,7 @@ bool Icon::loadPixmap(std::string iconFilename)
if(! XpmCreatePixmapFromData(dpy,
icon_win,
- default_icon_xpm,
+ (char **)default_icon_xpm,
&icon_pixmap,
&icon_pixmap_mask,
&icon_pixmap_attr)==XpmSuccess)
--- goodies/appbar/icon.hh.orig 2005-01-03 21:54:58 UTC
+++ goodies/appbar/icon.hh
@@ -43,8 +43,6 @@
#include <X11/extensions/shape.h>
#include <stdlib.h>
-extern char * default_icon_xpm[];
-
class Icon
{
private:
--- goodies/appbar/image.cc.orig 2005-01-03 21:54:58 UTC
+++ goodies/appbar/image.cc
@@ -24,6 +24,7 @@
#endif
#include "image.hh"
+#include <cstdlib>
#ifndef MIN
# define MIN(a, b) ((a < b) ? a : b)
--- goodies/appbar/main.cc.orig 2005-01-03 21:54:58 UTC
+++ goodies/appbar/main.cc
@@ -33,6 +33,9 @@
* Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.
*/
+#include <iostream>
+using namespace std;
+
#include "appbar.hh"
int main(int argc, char* argv[])
--- goodies/appbar/scanner.cc.orig 2005-01-03 21:54:58 UTC
+++ goodies/appbar/scanner.cc
@@ -156,7 +156,7 @@ void Scanner::concat(int type)
{
s_token.empty();
- while(char_class[character]==type)
+ while(char_class[(int) character]==type)
{
s_token += character;
@@ -177,7 +177,7 @@ void Scanner::getNextToken(bool spaces)
if (!spaces) {
char_class[' ']=whitespace;
- while(char_class[character]==whitespace)
+ while(char_class[(int)character]==whitespace)
{
if( inputFile.eof() ) return;
@@ -192,7 +192,7 @@ void Scanner::getNextToken(bool spaces)
}
}
- if (! inputFile.eof() ) { concat( char_class[character] ); }
+ if (! inputFile.eof() ) { concat( char_class[(int)character] ); }
}
bool Scanner::match( std::string m )
--- goodies/fspanel/Makefile.orig 2005-01-03 21:54:58 UTC
+++ goodies/fspanel/Makefile
@@ -1,7 +1,9 @@
-CC = gcc
-C_FLAGS = -DNOSTDLIB -DHAVE_XPM -Wall -I$(XROOT)/include -m386 -malign-loops=2 -malign-jumps=2 -malign-functions=2
+CC ?= gcc
+C_FLAGS = -DNOSTDLIB -DHAVE_XPM -Wall -I$(XROOT)/include -falign-functions=2 --std=c++14
L_FLAGS = -O1 -Xlinker -s -L$(XROOT)/lib -lX11 -lXpm
PROGNAME = fspanel
+
+all: $(PROGNAME)
$(PROGNAME): Makefile fspanel.c fspanel.h icon.xpm
$(CC) $(C_FLAGS) $(L_FLAGS) fspanel.c -o $(PROGNAME)
@@ -14,4 +16,4 @@ uninstall:
cp -r $(PROGNAME) $(DESTDIR)$(prefix)/bin
uninstall:
- rm $(DESTDIR)$(prefix)/bin/$(PROGNAME)
\ No newline at end of file
+ rm $(DESTDIR)$(prefix)/bin/$(PROGNAME)
--- goodies/fspanel/fspanel.c.orig 2005-01-03 21:54:58 UTC
+++ goodies/fspanel/fspanel.c
@@ -179,7 +179,7 @@ void turn_off_strut()
XDeleteProperty(dd, win, net_wm_strut);
}
-void *get_prop_data (Window win, Atom prop, Atom type, int *items)
+unsigned long*get_prop_data (Window win, Atom prop, Atom type, int *items)
{
Atom type_ret;
int format_ret;
@@ -195,7 +195,7 @@ void *get_prop_data (Window win, Atom prop, Atom type,
if (items)
*items = items_ret;
- return prop_data;
+ return (unsigned long *)prop_data;
}
void get_task_hinticon (task *tk)
@@ -393,7 +393,8 @@ void scale_icon (task *tk)
void scale_icon (task *tk)
{
- int xx, yy, x, y, w, h, d, bw;
+ int xx, yy, x, y;
+ unsigned int w, h, d, bw;
Pixmap pix, mk = None;
XGCValues gcv;
GC mgc=None;
@@ -746,7 +747,7 @@ taskbar *gui_create_taskbar (void)
XMapWindow (dd, win);
- tb = calloc (1, sizeof (taskbar));
+ tb = (taskbar *)calloc (1, sizeof (taskbar));
tb->win = win;
return tb;
@@ -760,10 +761,10 @@ void add_task (taskbar * tb, Window win, int focus)
if (tb->my_desktop != find_desktop (win) || is_hidden (win))
return;
- tk = calloc (1, sizeof (task));
+ tk = (task *)calloc (1, sizeof (task));
tk->win = win;
tk->focused = focus;
- tk->name = get_prop_data (win, XA_WM_NAME, XA_STRING, 0);
+ tk->name = (char *)(void *)get_prop_data (win, XA_WM_NAME, XA_STRING, 0);
tk->iconified = is_iconified (win);
get_task_kdeicon (tk);
@@ -1075,7 +1076,7 @@ void handle_propertynotify (taskbar * tb, Window win,
/* window's title changed */
if (tk->name)
XFree (tk->name);
- tk->name = get_prop_data (tk->win, XA_WM_NAME, XA_STRING, 0);
+ tk->name = (char *)(void *)get_prop_data (tk->win, XA_WM_NAME, XA_STRING, 0);
gui_draw_task (tb, tk);
} else if (at == atom_WM_STATE)
{
--- goodies/fspanel/fspanel.h.orig 2005-01-03 21:54:58 UTC
+++ goodies/fspanel/fspanel.h
@@ -55,7 +55,7 @@ void set_top_strut();
void set_bottom_strut();
void set_top_strut();
-void *get_prop_data (Window win, Atom prop, Atom type, int *items);
+unsigned long *get_prop_data (Window win, Atom prop, Atom type, int *items);
void set_foreground (int index);
void draw_line (taskbar *tb, int x, int y, int a, int b);
void fill_rect (taskbar *tb, int x, int y, int a, int b);
--- goodies/setrootimage/Makefile.orig 2005-01-03 21:54:58 UTC
+++ goodies/setrootimage/Makefile
@@ -1,5 +1,5 @@
-CC = g++
-CFLAGS = -g -O2 -Wall
+CC ?= g++
+CFLAGS ?= -g -O2 -Wall
INCLUDES = -I$(XROOT)/include
LIBS = -lX11 -lXext
LDPATH = -L$(XROOT)/lib
--- goodies/setrootimage/image.cc.orig 2005-01-03 21:54:58 UTC
+++ goodies/setrootimage/image.cc
@@ -24,6 +24,7 @@
#endif
#include "image.hh"
+#include <cstdlib>
#ifndef MIN
# define MIN(a, b) ((a < b) ? a : b)
--- goodies/setrootimage/image.hh.orig 2005-01-03 21:54:58 UTC
+++ goodies/setrootimage/image.hh
@@ -27,6 +27,7 @@
#include <cstdio>
#include <list>
+using namespace std;
class BImageControl;
class BImage;
--- goodies/setrootimage/setrootimage.cc.orig 2005-01-03 21:54:58 UTC
+++ goodies/setrootimage/setrootimage.cc
@@ -31,6 +31,9 @@
* Released under the GNU GPL license
* www.gnu.org
*/
+#include <iostream>
+using namespace std;
+
#include <X11/Xlib.h>
#include <X11/xpm.h>
#include <stdlib.h>
@@ -56,10 +59,11 @@ BColor parseCommandlineColor(char* the_color)
temp_blue[1] = the_color[i];
}
- color.red = strtol(temp_red,0,16);
+ color.pixel = 0;
+ color.red = strtol(temp_red,0,16);
color.green = strtol(temp_green,0,16);
color.blue = strtol(temp_blue,0,16);
-
+
return color;
}
@@ -86,10 +90,10 @@ int main (int argc, char * argv[])
Pixmap root_pix = None;
BColor to, from;
- char* opt_color="no color";
- char* opt_from="708090";
- char* opt_to="ffffff";
- char* opt_display="";
+ char* opt_color=(char *)"no color";
+ char* opt_from=(char *)"708090";
+ char* opt_to=(char *)"ffffff";
+ char* opt_display=(char *)"";
int width=0;
int height=0;
--- goodies/xsession/Makefile.orig 2005-01-03 21:54:58 UTC
+++ goodies/xsession/Makefile
@@ -1,9 +1,11 @@ CC = gcc
# Taken from fspanel Makefile by MJR
CC = gcc
-C_FLAGS = -DNOSTDLIB -DHAVE_XPM -Wall -I$(XROOT)/include -m386 -malign-loops=2 -malign-jumps=2 -malign-functions=2
+C_FLAGS = -DNOSTDLIB -DHAVE_XPM -Wall -I$(XROOT)/include -falign-functions=2
L_FLAGS = -O1 -Xlinker -s -L$(XROOT)/lib -lX11 -lXpm
PROGNAME = xsession
+
+all: $(PROGNAME)
$(PROGNAME): Makefile xsession.c
$(CC) $(C_FLAGS) $(L_FLAGS) xsession.c -o $(PROGNAME)
--- windowmanager.cc.orig 2005-01-03 21:54:59 UTC
+++ windowmanager.cc
@@ -51,24 +51,24 @@ WindowManager::WindowManager(int argc, char** argv)
// Set the global window manager object to this please =)
wm = this;
- window_manager_name="jewel";
+ window_manager_name=(char *)"jewel";
// Make the default options equal something
- opt_font = DEF_FONT;
- opt_fm = DEF_FM;
- opt_fg = DEF_FG;
- opt_fc = DEF_FC;
- opt_bg = DEF_BG;
- opt_bd = DEF_BD;
- opt_tj = TEXT_JUSTIFY;
- opt_wm = WIRE_MOVE;
- opt_es = EDGE_SNAP;
- opt_newkey = DEF_NEWKEY;
- opt_new1 = DEF_NEW1;
- opt_new2 = DEF_NEW2;
+ opt_font = (char *)DEF_FONT;
+ opt_fm = (char *)DEF_FM;
+ opt_fg = (char *)DEF_FG;
+ opt_fc = (char *)DEF_FC;
+ opt_bg = (char *)DEF_BG;
+ opt_bd = (char *)DEF_BD;
+ opt_tj = (char *)TEXT_JUSTIFY;
+ opt_wm = (char *)WIRE_MOVE;
+ opt_es = (char *)EDGE_SNAP;
+ opt_newkey = (char *)DEF_NEWKEY;
+ opt_new1 = (char *)DEF_NEW1;
+ opt_new2 = (char *)DEF_NEW2;
opt_bw = DEF_BW;
opt_display=NULL;
- maxDesktops=MAX_DESKTOPS;
+ maxDesktops=MAX_DESKTOPS;
// These macro's are nice to test values passed in
// the command line arguments
@@ -1557,21 +1557,21 @@ void WindowManager::focusNextWindowInStackingOrder()
// find the client in the list...
it = find(clientList->begin(), clientList->end(), c);
- if ( it == NULL || it == clientList->end()) {
+ if ( it == clientList->end()) {
it = clientList->begin();
}
do {
cycles++;
- if ( it != clientList->end() && it != NULL ) {
+ if ( it == clientList->end() ) {
+ it = clientList->begin();
+ }
+ else {
it++;
if ( it == clientList->end() ) {
it = clientList->begin();
}
}
- else {
- it = clientList->begin();
- }
} while (cycles < clientList->size() && (shouldSkipThisWindow((*it)->getAppWindow()) || (*it)->isIconified() || (*it)->belongsToWhichDesktop() != currentDesktop));
#ifdef DEBUG
@@ -1588,7 +1588,7 @@ void WindowManager::focusNextWindowInStackingOrder()
// if we found a suitable "next client", raise and focus
// it; otherwise, leave focus where it is
- if ( cycles < clientList->size() && it != NULL && it != clientList->end() && !shouldSkipThisWindow((*it)->getAppWindow()) && !(*it)->isIconified() && (*it)->belongsToWhichDesktop() == currentDesktop && !shouldSkipThisWindow((*it)->getAppWindow())) {
+ if ( cycles < clientList->size() && !(it == clientList->end()) && !shouldSkipThisWindow((*it)->getAppWindow()) && !(*it)->isIconified() && (*it)->belongsToWhichDesktop() == currentDesktop && !shouldSkipThisWindow((*it)->getAppWindow())) {
c = *it;
c->raise();
setFocusedClient(c);
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Please register or to comment