Skip to content
Snippets Groups Projects
Commit e550af7d authored by Rene Ladan's avatar Rene Ladan
Browse files

www/Stikked: Remove expired port

2024-12-31 www/Stikked: Broken with PHP 8+ (see PR 281858)
parent 756803d3
No related branches found
No related tags found
No related merge requests found
......@@ -3846,3 +3846,4 @@ security/py-first-server||2025-01-01|Has expired: Upstream project has been arch
security/maia||2025-01-01|Has expired: Depends on deprecated dependencies and doesn't work with PHP 8
devel/grv||2025-01-01|Has expired: Unmaintained for years, outdated
deskutils/basket||2025-01-01|Has expired: Unmaintained for years, fails to build with libgit 1.8.1
www/Stikked||2025-01-01|Has expired: Broken with PHP 8+ (see PR 281858)
......@@ -20,7 +20,6 @@
SUBDIR += R-cran-shiny
SUBDIR += R-cran-shinyjs
SUBDIR += R-cran-webshot
SUBDIR += Stikked
SUBDIR += UniversalFeedCreator
SUBDIR += adguardhome
SUBDIR += adjuster
......
PORTNAME= Stikked
DISTVERSION= 0.14.0
PORTREVISION= 2
CATEGORIES= www
MAINTAINER= ports@FreeBSD.org
COMMENT= PHP-based Pastebin, with a simple and easy to use user interface
WWW= https://github.com/claudehohl/Stikked
DEPRECATED= Broken with PHP 8+ (see PR 281858)
EXPIRATION_DATE= 2024-12-31
USES= php:web
USE_GITHUB= yes
GH_ACCOUNT= claudehohl
USE_PHP= ctype filter gd session
NO_BUILD= yes
NO_ARCH= yes
SUB_FILES= pkg-message
OPTIONS_MULTI= DB
OPTIONS_MULTI_DB= MYSQL PGSQL SQLITE
OPTIONS_DEFAULT= PGSQL
MYSQL_DESC= Include the PHP shared extension for MySQL
PGSQL_DESC= Include the PHP shared extension for PostgreSQL
SQLITE_DESC= Include the PHP shared extension for SQLite3
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MMYSQL}
USE_PHP+= mysqli
.endif
.if ${PORT_OPTIONS:MPGSQL}
USE_PHP+= pgsql
.endif
.if ${PORT_OPTIONS:MSQLITE}
USE_PHP+= sqlite3
.endif
do-install:
${MKDIR} ${STAGEDIR}${ETCDIR}
${MKDIR} ${STAGEDIR}${WWWDIR}
(cd ${WRKSRC}/htdocs && ${COPYTREE_SHARE} . ${STAGEDIR}${WWWDIR})
${INSTALL_DATA} ${STAGEDIR}${WWWDIR}/application/config/stikked.php.dist ${STAGEDIR}${ETCDIR}/stikked.php.sample
${LN} -sf ${ETCDIR}/stikked.php ${STAGEDIR}${WWWDIR}/application/config/
.include <bsd.port.mk>
TIMESTAMP = 1655555745
SHA256 (claudehohl-Stikked-0.14.0_GH0.tar.gz) = 50a2540c234484b44dba713553c15f3a96da00cb7067e976e9ad49c3be1eec5a
SIZE (claudehohl-Stikked-0.14.0_GH0.tar.gz) = 10648711
--- htdocs/application/config/stikked.php.dist.orig 2019-11-24 16:10:45 UTC
+++ htdocs/application/config/stikked.php.dist
@@ -19,6 +19,19 @@ $config['site_name'] = 'Stikked';
$config['base_url'] = 'https://yourpastebin.com/';
/**
+ * TruePaste
+ *
+ * Should pastes be converted to HTML entities before saving.
+ *
+ * Default, for backwards compatibility, is false.
+ *
+ * Set to true if you want your paste to be saved as supplied.
+*/
+
+$config['true_paste'] = true;
+
+
+/**
* Database connection
*
* Credentials for your database
--- htdocs/application/models/Pastes.php.orig 2022-06-18 12:47:43 UTC
+++ htdocs/application/models/Pastes.php
@@ -32,8 +32,16 @@ class Pastes extends CI_Model
{
$data['created'] = time();
- //this is SO evil… saving the «raw» data with htmlspecialchars :-( (but I have to leave this, because of backwards-compatibility)
- $data['raw'] = htmlspecialchars($this->_strip_bad_multibyte_chars($this->input->post('code')));
+ if ($this->config->item('true_paste'))
+ {
+ // save the paste as supplied
+ $data['raw'] = $this->input->post('code');
+ }
+ else
+ {
+ //this is SO evil… saving the «raw» data with htmlspecialchars :-( (but I have to leave this, because of backwards-compatibility)
+ $data['raw'] = htmlspecialchars($this->_strip_bad_multibyte_chars($this->input->post('code')));
+ }
$data['lang'] = htmlspecialchars($this->input->post('lang'));
$data['replyto'] = ($this->input->post('reply') === null ? '0' : $this->input->post('reply'));
[
{ type: install
message: <<EOM
The configuration file is in %%ETCDIR%%/stikked.php
This package contains a true_paste feature which has been sent
upstream but has not yet been included.
There are the minimal configuration items:
Set driver to one of:
* 'postgre'
* 'mysqli'
* 'sqlite'
Set appropriate values in the 'Database connection' section.
EOM
}
]
Stikked is an Open-Source PHP Pastebin, with the aim of keeping a simple and
easy to use user interface. Stikked allows you to easily share code with anyone
you wish. Based on the original Stikked with lots of bugfixes and improvements.
Prerequisites
* Webservers: Apache, Lighttpd, Nginx, Cherokee
* Databases: MySQL, PostgreSQL, SQLite
* PHP version 5.6 or newer
* PHP-GD for the creation of QR-codes
Here are some features:
* Easy setup
* Syntax highlighting for many languages
* Paste replies
* Diff view between the original paste and the reply
* An API
* Search pastes
* Encrypted pastes
* Burn on reading
* Anti-Spam features
This diff is collapsed.
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment