Skip to content
Snippets Groups Projects
Commit d50aa3a0 authored by Muhammad Moinur Rahman's avatar Muhammad Moinur Rahman
Browse files

sysutils/istatserver: Remove expired port

2023-09-30 sysutils/istatserver: Upstream last activity was in 2018
parent 6c08bf5b
No related branches found
No related tags found
No related merge requests found
......@@ -7904,3 +7904,4 @@ net/openldap24-client|net/openldap25-client|2023-09-30|Has expired: No longer su
net/openldap24-server|net/openldap25-server|2023-09-30|Has expired: No longer supported by upstream. Please use a newer version of OpenLDAP instead
science/crf++||2023-09-30|Has expired: Last upstream activity was in 2015
security/fwbuilder||2023-09-30|Has expired: Abandonware since Jan 2021
sysutils/istatserver||2023-09-30|Has expired: Upstream last activity was in 2018
......@@ -600,7 +600,6 @@
SUBDIR += ipsc
SUBDIR += isc-cron
SUBDIR += isomaster
SUBDIR += istatserver
SUBDIR += istio
SUBDIR += jadm
SUBDIR += jail-primer
......
PORTNAME= istatserver
PORTVERSION= 3.02
PORTREVISION= 2
CATEGORIES= sysutils
MASTER_SITES= https://s3.amazonaws.com/bjango/files/istatserverlinux/
MAINTAINER= farrokhi@FreeBSD.org
COMMENT= Daemon for iStat iPhone application
WWW= https://bjango.com/linux/istatserver/
LICENSE= BSD3CLAUSE
DEPRECATED= Upstream last activity was in 2018
EXPIRATION_DATE= 2023-09-30
BROKEN_FreeBSD_14= fails to compile undefined symbol: RSA_generate_key
LIB_DEPENDS= libxml2.so:textproc/libxml2 \
libsqlite3.so:databases/sqlite3
USES= ssl
GNU_CONFIGURE= yes
USE_RC_SUBR= ${PORTNAME}
USERS= istat
GROUPS= istat
SUB_FILES= pkg-message
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/istatserver ${STAGEDIR}${PREFIX}/bin
${MKDIR} ${STAGEDIR}${PREFIX}/etc/istatserver
${INSTALL_DATA} ${WRKSRC}/resource/istatserver.conf \
${STAGEDIR}${PREFIX}/etc/istatserver/istatserver.conf.sample
${INSTALL_DATA} ${WRKSRC}/resource/istatserver_generated.conf \
${STAGEDIR}${PREFIX}/etc/istatserver/istatserver_generated.conf.sample
${INSTALL_MAN} ${WRKSRC}/resource/istatserver.1 \
${STAGEDIR}${MANPREFIX}/man/man1
${INSTALL_MAN} ${WRKSRC}/resource/istatserver.conf.5 \
${STAGEDIR}${MANPREFIX}/man/man5
@${ECHO_CMD} '@postexec ${CHOWN} -R ${USERS}:${GROUPS} %D/etc/istatserver' >> ${TMPPLIST}
.include <bsd.port.mk>
TIMESTAMP = 1501935033
SHA256 (istatserver-3.02.tar.gz) = e56fa1dd30847a9a75db2981807ae359b043f715d7fc8c33464b0b3e88e5bf38
SIZE (istatserver-3.02.tar.gz) = 198541
#!/bin/sh
# PROVIDE: istatserver
# REQUIRE: LOGIN
#
# Add the following lines to /etc/rc.conf.local or /etc/rc.conf
# to enable this service:
#
# istatd_enable (bool): Set to NO by default.
# Set it to YES to enable istatd.
#
. /etc/rc.subr
name="istatserver"
rcvar=istatserver_enable
command=%%PREFIX%%/bin/${name}
load_rc_config $name
: ${istatserver_enable="NO"}
: ${istatserver_config="%%PREFIX%%/etc/istatserver/istatserver.conf"}
command_args="-d -c $istatserver_config"
run_rc_command "$1"
--- src/Daemon.cpp.orig 2018-06-09 07:03:35 UTC
+++ src/Daemon.cpp
@@ -174,7 +174,7 @@ void Daemon::create(bool _back, const st
length = offsetof(struct sockaddr_un, sun_path) + strlen(sockfile.c_str());
- if (bind(unix_socket, (struct sockaddr *) &local, length) == -1)
+ if (::bind(unix_socket, (struct sockaddr *) &local, length) == -1)
{
cout << "Could not bind UNIX socket: " << strerror(errno) << endl;
exit(1);
[
{ type: install
message: <<EOM
%%PREFIX%%/etc/istatserver/istatserver.conf is the daemon's configuration file.
Please edit the "server_code" framework with a unique numeric code for your
server.
EOM
}
]
istatserver is a daemon serving statistics to your iStat iPhone application
from Linux, Solaris & FreeBSD. istatserver collects data such as CPU, memory,
network and disk usage and keeps the history. Once connecting from the
iPhone and entering the lock code this data will be sent to the iPhone
and shown in fancy graphs.
bin/istatserver
@sample etc/istatserver/istatserver.conf.sample
@sample etc/istatserver/istatserver_generated.conf.sample
man/man1/istatserver.1.gz
man/man5/istatserver.conf.5.gz
0% Loading or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment