Commit 8972b991 authored by Francis's avatar Francis
Browse files

Added docker image to CI

parent d28eb21f
Pipeline #79047943 passed with stage
in 5 minutes and 7 seconds
image: ruby:2.6
stages:
- prepare
- codecheck
- test
environment-setup:
stage: prepare
test:
stage: test
script:
- gem install bundler -v 1.17.3
- bundle install
rubocop:
stage: codecheck
script:
- rubocop
minitest:
stage: test
script:
- rake
\ No newline at end of file
......@@ -8,7 +8,6 @@ GEM
remote: https://rubygems.org/
specs:
ast (2.4.0)
dotenv (2.7.4)
jaro_winkler (1.5.3)
minitest (5.11.3)
parallel (1.17.0)
......@@ -17,7 +16,7 @@ GEM
rainbow (3.0.0)
rake (10.5.0)
redis (4.1.2)
rubocop (0.72.0)
rubocop (0.74.0)
jaro_winkler (~> 1.5.1)
parallel (~> 1.10)
parser (>= 2.6)
......@@ -32,8 +31,6 @@ PLATFORMS
DEPENDENCIES
blizzard_api!
bundler (~> 1.17.3, >= 1.17.3)
dotenv (~> 2.5)
minitest (~> 5.0)
rake (~> 10.0)
rubocop (~> 0.61)
......
......@@ -34,7 +34,6 @@ Gem::Specification.new do |spec|
spec.add_runtime_dependency 'redis', '~> 4.1', '>= 4.1.0'
spec.add_development_dependency 'bundler', '~> 1.17.3', '>= 1.17.3'
spec.add_development_dependency 'minitest', '~> 5.0'
spec.add_development_dependency 'rake', '~> 10.0'
spec.add_development_dependency 'rubocop', '~> 0.61'
......
......@@ -2,7 +2,6 @@
$LOAD_PATH.unshift File.expand_path('../lib', __dir__)
require 'minitest/autorun'
require 'dotenv/load'
require 'blizzard_api'
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment