Commit ffd10e60 authored by David Llewellyn-Jones's avatar David Llewellyn-Jones

Updated Functy README with improved install instructions, and updated the...

Updated Functy README with improved install instructions, and updated the build configuration to include glee.
parent 1dfc55f4
......@@ -9,11 +9,20 @@ Install
Note that to build Functy you must first install libsymbolic. This should be available from the same place you obtained Functy. Once you've installed libsymbolic, continue with the instructions below.
If you have autoconf you should be able to install using the following 3 commands:
You'll need the autoconf tools in order to build Functy. They should be available in your distributions repository (e.g. in Ubuntu 13.04 they're available as the "autoconf" package). Once you have these, you should then execute the following command inside the Functy folder before continuing.
autoreconf --install
This will install the correct autotools files inside the folder. You can then continue to build and install Functy using the following 3 commands:
./configure
make
make install
sudo make install
Once built, you can execute Functy with the command
functy
License
=======
......
......@@ -29,6 +29,7 @@ AC_C_CONST
AC_C_INLINE
# Checks for library functions.
AC_SEARCH_LIBS([GLeeEnabled], [glee GLee], [], [])
AC_FUNC_STRTOD
AC_CHECK_FUNCS([floor ftime pow sqrt])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment