Commit 65f935b3 authored by David Llewellyn-Jones's avatar David Llewellyn-Jones

Require libzip >= 0.11

The zip_discard function is needed in case an export is cancelled by
the user. zip_discard was introduced in libzip 0.11, see
http://hg.nih.at/libzip/rev/89c0621dc011 so the dependency has
been adjusted to reflect this.
parent d44f7d93
......@@ -4465,12 +4465,12 @@ if test -n "$FUNCTY_CFLAGS"; then
pkg_cv_FUNCTY_CFLAGS="$FUNCTY_CFLAGS"
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw\""; } >&5
($PKG_CONFIG --exists --print-errors "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw") 2>&5
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip >= 0.11, libpng, libpulse-mainloop-glib, fftw3, ncursesw\""; } >&5
($PKG_CONFIG --exists --print-errors "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip >= 0.11, libpng, libpulse-mainloop-glib, fftw3, ncursesw") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
pkg_cv_FUNCTY_CFLAGS=`$PKG_CONFIG --cflags "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw" 2>/dev/null`
pkg_cv_FUNCTY_CFLAGS=`$PKG_CONFIG --cflags "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip >= 0.11, libpng, libpulse-mainloop-glib, fftw3, ncursesw" 2>/dev/null`
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
......@@ -4482,12 +4482,12 @@ if test -n "$FUNCTY_LIBS"; then
pkg_cv_FUNCTY_LIBS="$FUNCTY_LIBS"
elif test -n "$PKG_CONFIG"; then
if test -n "$PKG_CONFIG" && \
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw\""; } >&5
($PKG_CONFIG --exists --print-errors "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw") 2>&5
{ { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip >= 0.11, libpng, libpulse-mainloop-glib, fftw3, ncursesw\""; } >&5
($PKG_CONFIG --exists --print-errors "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip >= 0.11, libpng, libpulse-mainloop-glib, fftw3, ncursesw") 2>&5
ac_status=$?
$as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
test $ac_status = 0; }; then
pkg_cv_FUNCTY_LIBS=`$PKG_CONFIG --libs "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw" 2>/dev/null`
pkg_cv_FUNCTY_LIBS=`$PKG_CONFIG --libs "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip >= 0.11, libpng, libpulse-mainloop-glib, fftw3, ncursesw" 2>/dev/null`
test "x$?" != "x0" && pkg_failed=yes
else
pkg_failed=yes
......@@ -4508,14 +4508,14 @@ else
_pkg_short_errors_supported=no
fi
if test $_pkg_short_errors_supported = yes; then
FUNCTY_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw" 2>&1`
FUNCTY_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip >= 0.11, libpng, libpulse-mainloop-glib, fftw3, ncursesw" 2>&1`
else
FUNCTY_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw" 2>&1`
FUNCTY_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip >= 0.11, libpng, libpulse-mainloop-glib, fftw3, ncursesw" 2>&1`
fi
# Put the nasty error message in config.log where it belongs
echo "$FUNCTY_PKG_ERRORS" >&5
as_fn_error $? "Package requirements (gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw) were not met:
as_fn_error $? "Package requirements (gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip >= 0.11, libpng, libpulse-mainloop-glib, fftw3, ncursesw) were not met:
$FUNCTY_PKG_ERRORS
......
......@@ -15,7 +15,7 @@ AM_PROG_CC_C_O
AC_LANG(C++)
# Checks for libraries.
PKG_CHECK_MODULES([FUNCTY], [gtk+-2.0 gdk-2.0 gtkglext-1.0 glee libzip, libpng, libpulse-mainloop-glib, fftw3, ncursesw])
PKG_CHECK_MODULES([FUNCTY], [gtk+-2.0 gdk-2.0 gtkglext-1.0 glee [libzip >= 0.11], libpng, libpulse-mainloop-glib, fftw3, ncursesw])
PKG_CHECK_MODULES([SYMBOLIC], [libsymbolic-1])
PKG_CHECK_MODULES([OPENVDB], [OpenEXR, tbb])
AC_CHECK_LIB([glut], [glutInit], [], [AC_MSG_ERROR([The glut library is missing.])])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment