Commit a821d1df authored by Toon Claes's avatar Toon Claes

Merge branch 'update-golang-version' into 'master'

Update Golang version

Closes #514

See merge request gitlab-org/gitlab-development-kit!692
parents 3f160d04 eaa4bfee
......@@ -23,8 +23,8 @@ ARG RUBY_BUILD_REVISION=v20190423
RUN git clone --branch $RUBY_BUILD_REVISION --depth 1 https://github.com/rbenv/ruby-build
FROM fetch AS go
ARG GO_SHA256=4b677d698c65370afa33757b6954ade60347aaca310ea92a63ed717d7cb0c2ff
ARG GO_VERSION=1.10.2
ARG GO_SHA256=aea86e3c73495f205929cfebba0d63f1382c8ac59be081b6351681415f4063cf
ARG GO_VERSION=1.12.5
RUN curl --silent --location --output go.tar.gz https://dl.google.com/go/go$GO_VERSION.linux-amd64.tar.gz
RUN echo "$GO_SHA256 go.tar.gz" | sha256sum -c -
RUN tar -C /usr/local -xzf go.tar.gz
......
......@@ -4,14 +4,14 @@ def version_to_a(v)
v.split('.').map(&:to_i)
end
MINIMAL_VERSION = "1.10"
MINIMAL_VERSION = "1.12"
version_output = ""
begin
version_output = `go version`
rescue Errno::ENOENT
abort "Go is not installed, please install Go #{MINIAL_VERSION} or higher"
abort "Go is not installed, please install Go #{MINIMAL_VERSION} or higher"
end
abort 'Could not determine version of Go' unless $?.success?
......
......@@ -16,7 +16,7 @@ Make sure you follow all the guidelines and resolve all the dependencies listed
| Bundler | <p>Install the version of Bundler specified in [Gemfile.lock](https://gitlab.com/gitlab-org/gitlab-ce/blob/master/Gemfile.lock). You will find it at the very bottom, right below the text `BUNDLED WITH`.</p><p> Use the command `gem install bundler -v <version>`, replacing `<version>` with the number you found above.</p> |
| Git | <p>We recommend using Git version 2.21 or higher.</p><p>git installation is covered in the instructions below</p> |
| Node.js | <p>Node.js **10.x (LTS)** or 8.x (LTS) and Yarn 1.12 or newer.</p><p>Node.js and Yarn installation is covered in the instructions below. If your package manager does not have Node.js 10.x or yarn available, visit the official websites for [Node](https://nodejs.org/en/download/) and [Yarn](https://yarnpkg.com/en/docs/install/) for installation instructions.</p> |
| Go | <p>Go 1.10 or newer.</p><p>Go installation is covered in the instructions below. If your package manager does not have up-to-date versions of Go available, visit the official [Go](https://golang.org/doc/install) website for installation instructions.</p> |
| Go | <p>Go 1.12 or newer.</p><p>Go installation is covered in the instructions below. If your package manager does not have up-to-date versions of Go available, visit the official [Go](https://golang.org/doc/install) website for installation instructions.</p> |
| Google Chrome | [Google Chrome](https://www.google.com/chrome/) 60 or greater with [ChromeDriver](https://sites.google.com/a/chromium.org/chromedriver/downloads) version 2.33 or greater. Visit the Chrome Driver [Getting started](https://sites.google.com/a/chromium.org/chromedriver/getting-started) page for more details. |
| PostgreSQL | <p>PostgreSQL version 10.x.</p><p>PostgreSQL installation is covered in the instructions below.</p> |
| GraphicsMagick | GraphicsMagick installation is covered in the instructions below. |
......@@ -87,7 +87,7 @@ Please read [the prerequisites for all platforms](#prerequisites-for-all-platfor
sudo add-apt-repository ppa:git-core/ppa
sudo apt-get update
sudo apt-get install git postgresql postgresql-contrib libpq-dev redis-server \
libicu-dev cmake g++ libre2-dev libkrb5-dev libsqlite3-dev golang-1.10-go ed \
libicu-dev cmake g++ libre2-dev libkrb5-dev libsqlite3-dev golang-1.12-go ed \
pkg-config graphicsmagick runit libimage-exiftool-perl rsync
```
1. You're all set now. [Go to next steps](#next-steps).
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment