Commit b1e81d36 authored by Matthias Andree's avatar Matthias Andree

Bump OpenSSL requirement to v1.0.2.

parent 4a57a634
......@@ -89,7 +89,7 @@ fetchmail-6.4.0 (not yet released):
## CHANGES
* fetchmail 6.3.X is unsupported.
* fetchmail now requires OpenSSL v1.0.1 or newer.
* fetchmail now requires OpenSSL v1.0.2 or newer.
* fetchmail now configures OpenSSL support by default.
* Fetchmail now supports --sslproto auto and --sslproto tls1+ (same as ssl23).
* --sslproto tls1.1+ and tls1.2+ are now supported for auto-negotiation with a
......
......@@ -28,7 +28,7 @@ and v3 are broken.
Quickstart
----------
Use an up-to-date release of OpenSSL 1.0.1 or newer, so as to get
Use an up-to-date release of OpenSSL 1.0.2 or newer, so as to get
TLSv1.2 support. Older OpenSSL versions are unsupported upstream, and
fetchmail rejects them.
......
......@@ -378,10 +378,10 @@ va_dcl {
#include <openssl/x509v3.h>
#include <openssl/rand.h>
#define fm_MIN_OPENSSL_VER 0x1000100fL
#define fm_MIN_OPENSSL_VER 0x1000200fL
#if OPENSSL_VERSION_NUMBER < fm_MIN_OPENSSL_VER
#error Your OpenSSL version must be at least 1.0.1 release. Older OpenSSL versions are unsupported.
#error Your OpenSSL version must be at least 1.0.2 release. Older OpenSSL versions are unsupported.
#else
/*
#define __fm_ossl_ver(x) #x
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment