Commit ddefec33 authored by est's avatar est

Add ndk 13b

parent d7ec3211
......@@ -4,6 +4,7 @@ ndk_paths = {
'r10e': "/home/vagrant/android-ndk/r10e",
'r11c': "/home/vagrant/android-ndk/r11c",
'r12b': "/home/vagrant/android-ndk/r12b",
'r13b': "/home/vagrant/android-ndk/r13b",
}
qt_sdk_path = "/home/vagrant/qt-sdk/5.7.0/5.7"
java_paths = {
......
......@@ -30,5 +30,10 @@ if [ ! -e $NDK_BASE/r12b ]; then
mv android-ndk-r12b r12b
fi
if [ ! -e $NDK_BASE/r13b ]; then
unzip /vagrant/cache/android-ndk-r13b-linux-x86_64.zip > /dev/null
mv android-ndk-r13b r13b
fi
chmod -R a+rX $NDK_BASE/
find $NDK_BASE/ -type f -executable -print0 | xargs -0 chmod a+x
......@@ -1122,9 +1122,9 @@ Version of the NDK to use in this build. Defaults to the latest NDK release
that included legacy toolchains, so as to not break builds that require
toolchains no longer included in current versions of the NDK.
The buildserver supports r9b with its legacy toolchains, r10e, r11c and the
latest release as of writing this document, r12b. You may add support
for more versions by adding them to 'ndk_paths' in your config file.
The buildserver supports r9b with its legacy toolchains, r10e, r11c, r12b,
and the latest release as of writing this document, r13b. You may add
support for more versions by adding them to 'ndk_paths' in your config file.
@item gradle=<flavour1>[,<flavour2>,...]
Build with Gradle instead of Ant, specifying what flavours to use. Flavours
......
......@@ -15,6 +15,7 @@
# 'r10e': None,
# 'r11c': None,
# 'r12b': "$ANDROID_NDK",
# 'r13b': None,
# }
# Path to the Qt SDK. It is of the form "/path/to/Qt5.7.0/5.7"
......
......@@ -59,6 +59,7 @@ default_config = {
'r10e': None,
'r11c': None,
'r12b': "$ANDROID_NDK",
'r13b': None,
},
'qt_sdk_path': None,
'build_tools': "25.0.0",
......
......@@ -291,6 +291,8 @@ cachefiles = [
'ba85dbe4d370e4de567222f73a3e034d85fc3011b3cbd90697f3e8dcace3ad94'),
('https://dl.google.com/android/repository/android-ndk-r12b-linux-x86_64.zip',
'eafae2d614e5475a3bcfd7c5f201db5b963cc1290ee3e8ae791ff0c66757781e'),
('https://dl.google.com/android/repository/android-ndk-r13b-linux-x86_64.zip',
'3524d7f8fca6dc0d8e7073a7ab7f76888780a22841a6641927123146c3ffd29c'),
('https://download.qt.io/official_releases/qt/5.7/5.7.0/qt-opensource-linux-x64-android-5.7.0.run',
'f7e55b7970e59bdaabb88cb7afc12e9061e933992bda2f076f52600358644586'),
]
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment