Commit 2c386dd5 authored by Marcus's avatar Marcus 🙈

riot: add 0.7.08-dev

Closes: fdroid/fdroiddata#1058
parent e515a0e7
Pipeline #16109468 passed with stage
in 1 minute and 48 seconds
......@@ -258,6 +258,67 @@ Build:0.7.03,70301
sed -i -e '/com.google.android.gms/d' build.gradle && \
sed -i -e '/com.google.gms.google-services/d' build.gradle
Build:0.7.08-dev,70800
commit=9da011858efc05d5e843e39aea78f849b47059f9
subdir=vector
sudo=apt-get update && \
apt-get install -y -t jessie-backports nodejs nodejs-legacy && \
curl -LOJ https://github.com/npm/npm/archive/v5.6.0.tar.gz && \
tar xvzf npm-5.6.0.tar.gz && \
cd npm-5.6.0 && \
make install && \
npm install -g react-native-cli
gradle=appfdroid
srclibs=matrixsdk@b2ea75e4bc172663570e89847134dcdc40108fae,olmsdk@18b067a46f575299a80349d2a5dce74b7dad88de,jitsi-meet@30b51ff3841b4b8d326e31dd1b7ec83a3024c39b,nodejs@v6.12.3
prebuild=sed -i -e '/com.google.firebase/d' build.gradle && \
sed -i -e '/com.google.gms.google-services/d' build.gradle && \
find . -name *.aar -exec truncate -s 0 {} \;
build=pushd $$nodejs$$ && \
./configure && \
make -j 4 && \
export PATH=$(readlink -f .):$PATH && \
popd && \
pushd $$olmsdk$$/android && \
echo ndk.dir=$$NDK$$ > local.properties && \
rm gradle.properties && \
gradle assembleRelease && \
popd && \
cp $$olmsdk$$/android/olm-sdk/build/outputs/aar/olm-sdk-release-2.2.2.aar libs/olm-sdk.aar && \
cp $$olmsdk$$/android/olm-sdk/build/outputs/aar/olm-sdk-release-2.2.2.aar $$matrixsdk$$/matrix-sdk/libs/olm-sdk.aar && \
pushd $$jitsi-meet$$ && \
npm install && \
make && \
pushd android && \
gradle assembleRelease && \
popd && \
react-native bundle --platform android --dev false --entry-file index.android.js --bundle-output index.android.bundle --assets-dest android/app/src/main/res/ && \
popd && \
cp $$jitsi-meet$$/android/sdk/build/outputs/aar/sdk-release.aar libs/jitsi-sdk.aar && \
cp $$jitsi-meet$$/node_modules/react-native-background-timer/android/build/outputs/aar/react-native-background-timer-release.aar libs/react-native-background-timer.aar && \
cp $$jitsi-meet$$/node_modules/react-native-fetch-blob/android/build/outputs/aar/react-native-fetch-blob-release.aar libs/react-native-fetch-blob.aar && \
cp $$jitsi-meet$$/node_modules/react-native-immersive/android/build/outputs/aar/react-native-immersive-release.aar libs/react-native-immersive.aar && \
cp $$jitsi-meet$$/node_modules/react-native-keep-awake/android/build/outputs/aar/react-native-keep-awake-release.aar libs/react-native-keep-awake.aar && \
cp $$jitsi-meet$$/node_modules/react-native-vector-icons/android/build/outputs/aar/react-native-vector-icons-release.aar libs/react-native-vector-icons.aar && \
cp $$jitsi-meet$$/node_modules/react-native-webrtc/android/build/outputs/aar/react-native-webrtc-release.aar libs/react-native-webrtc.aar && \
cp $$jitsi-meet$$/node_modules/react-native-webrtc/android/build/outputs/aar/react-native-webrtc-release.aar $$matrixsdk$$/matrix-sdk/libs/react-native-webrtc.aar && \
cp $$jitsi-meet$$/node_modules/react-native-locale-detector/android/build/outputs/aar/react-native-locale-detector-release.aar libs/react-native-locale-detector.aar && \
cp $$jitsi-meet$$/node_modules/react-native/android/com/facebook/react/react-native/0.50.4/react-native-0.50.4.aar libs/react-native.aar && \
cp $$jitsi-meet$$/node_modules/react-native-vector-icons/Fonts/*.ttf src/main/assets/fonts/ && \
cp $$jitsi-meet$$/index.android.bundle src/main/assets/ && \
pushd $$matrixsdk$$ && \
gradle clean assembleRelease && \
popd && \
cp $$matrixsdk$$/matrix-sdk/build/outputs/aar/matrix-sdk-release-*.aar libs/matrix-sdk.aar
Maintainer Notes:
Upstream puts their library aars inside the repo, we need build them our self. We truncate instead of deleting them such that the initial gradle clean is successful.
jitsi-meet needs react-native which we get via npm for now. This pulls in a few prebuilt binaries for now :-/.
We also need to provide an up to date version of npm and nodejs, neither of which can be found in debian jessie.i
We first install nodejs from backports to be able to install npm from their github archive.
Afterwards we build nodejs 6.x LTS from source which can be used to build jitsi AND compiles on debian jessie.
Then we walk through olmsdk, jitsi-meet, matrixsdk (which needs those other two, at least partly) and finally riot, which needs all three dependencies.
.
Auto Update Mode:None
Update Check Mode:Tags
Current Version:0.7.03
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment