Commit dcc50b66 authored by linsui's avatar linsui Committed by linsui
Browse files

misc fixes

parent d8356c8e
Pipeline #322658551 passed with stage
in 5 minutes and 17 seconds
......@@ -8,6 +8,7 @@ AuthorWebSite: https://plus.google.com/102332121455682860724
SourceCode: https://github.com/Adonai/Man-Man
IssueTracker: https://github.com/Adonai/Man-Man/issues
Donate: https://www.patreon.com/kanedias
Liberapay: Kanedias
AutoName: Man Man
Description: |-
......@@ -173,6 +174,7 @@ Builds:
subdir: app
gradle:
- fdroid
prebuild: sed -i -e 's/= URI.create//' ../build.gradle
AutoUpdateMode: Version %v
UpdateCheckMode: Tags
......
......@@ -33,16 +33,9 @@ Builds:
gradle:
- yes
- versionName: 1.1.9.4
versionCode: 47
commit: v1.1.9.4
subdir: app
gradle:
- yes
AutoUpdateMode: Version v%v
UpdateCheckMode: Tags
CurrentVersion: 1.1.9.4
CurrentVersionCode: 47
AutoUpdateMode: None
UpdateCheckMode: None
CurrentVersion: 1.1.8.0
CurrentVersionCode: 37
NoSourceSince: 1.1.8.0
......@@ -70,7 +70,7 @@ Builds:
prebuild: $ANDROID_HOME/tools/bin/sdkmanager 'cmake;3.10.2.4988404'
ndk: r20b
- versionName: v2.1.1
- versionName: 2.1.1
versionCode: 11
commit: v2.1.1
subdir: android/app
......@@ -85,5 +85,6 @@ Builds:
AutoUpdateMode: Version
UpdateCheckMode: Tags
CurrentVersion: v2.1.1
UpdateCheckData: android/app/build.gradle|versionCode\s(\d+)||v([\d.]+)
CurrentVersion: 2.1.1
CurrentVersionCode: 11
......@@ -81,6 +81,7 @@ Builds:
- $$flutter$$/bin/flutter pub get
- $$flutter$$/bin/flutter pub run build_runner build
- $$flutter$$/bin/flutter build apk
ndk: r21
MaintainerNotes: |-
Builds will fail when the srclib ref of flutter and the version with which
......
......@@ -59,28 +59,18 @@ Builds:
- $$flutter$$/bin/flutter config --no-analytics
- $$flutter$$/bin/flutter build apk --no-tree-shake-icons
- versionName: 1.12.4
versionCode: 25
disable: https://github.com/git-touch/git-touch/issues/239
commit: v1.12.4
output: build/app/outputs/flutter-apk/app-release.apk
srclibs:
- flutter@1.22.5
build:
- $$flutter$$/bin/flutter config --no-analytics
- $$flutter$$/bin/flutter build apk --no-tree-shake-icons
- versionName: 1.13.0
versionCode: 26
disable: https://github.com/git-touch/git-touch/issues/239
commit: v1.13.0
output: build/app/outputs/flutter-apk/app-release.apk
srclibs:
- flutter@1.22.5
- flutter@2.2.2
build:
- $$flutter$$/bin/flutter config --no-analytics
- $$flutter$$/bin/flutter build apk --no-tree-shake-icons
AutoUpdateMode: Version
AutoUpdateMode: None
UpdateCheckMode: Tags ^v.*$
UpdateCheckData: pubspec.yaml|version:\s.+\+(\d+)|.|version:\s(.+)\+
CurrentVersion: 1.13.0
......
......@@ -39,18 +39,11 @@ Builds:
- sed -i 's@\(reference.1=\).*@\1$$ActionBar$$@;/musicbrainz/d' project.properties
- echo 'source.dir=src;$$MusicBrainz-API$$/src' > ant.properties
- versionName: '1.3'
versionCode: 6
commit: '1.3'
srclibs:
- MusicBrainz-API@1.2.5
- ActionBar@093a5f80
prebuild:
- rm -rf $$MusicBrainz-API$$/src/test
- sed -i 's@\(reference.1=\).*@\1$$ActionBar$$@;/musicbrainz/d' project.properties
- echo 'source.dir=src;$$MusicBrainz-API$$/src' > ant.properties
MaintainerNotes: Use PayPal_MPL-1.5.5.45.jar
AutoUpdateMode: None
UpdateCheckMode: None
CurrentVersion: '1.1'
CurrentVersionCode: 2
AutoUpdateMode: Version
UpdateCheckMode: Tags
CurrentVersion: '1.3'
CurrentVersionCode: 6
NoSourceSince: '1.1'
......@@ -328,6 +328,7 @@ Builds:
- $$SDK$$/tools/bin/sdkmanager 'platforms;android-30' 'build-tools;30.0.3' >
/dev/null
- sed -i -e "/^task updateSdkLicences/,/^}/d; /commandLine 'git'/d" build.gradle
- sed -i -e '/android {/a ndkVersion = "20.1.5948944"' ../ics-openvpn/main/build.gradle.kts
scandelete:
- bitmask-core
- bitmask-web-core
......
......@@ -162,6 +162,7 @@ Builds:
- $$SDK$$/tools/bin/sdkmanager 'platforms;android-30' 'build-tools;30.0.3' >
/dev/null
- sed -i -e "/^task updateSdkLicences/,/^}/d; /commandLine 'git'/d" build.gradle
- sed -i -e '/android {/a ndkVersion = "20.1.5948944"' ../ics-openvpn/main/build.gradle.kts
scandelete:
- bitmask-core
- bitmask-web-core
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment