Commit 51e2ad36 authored by Licaon_Kter's avatar Licaon_Kter

Misc fixes after cycle

parent cf4d9a74
......@@ -18,6 +18,9 @@ Builds:
commit: 2.1.3
subdir: app
submodules: true
sudo:
- apt-get update || apt-get update
- apt-get install -y --no-install-recommends libgmp-dev
patch:
- openvpn-build.patch
gradle:
......
......@@ -130,6 +130,7 @@ Builds:
- versionName: 0.16.0
versionCode: 16
disable: fails to build
commit: 0.16.0
subdir: android
sudo:
......
......@@ -476,6 +476,7 @@ MaintainerNotes: |-
scanignore is used to allow the "node_modules/react-native/android" local Maven repository.
ArchivePolicy: 4 versions
AutoUpdateMode: None
UpdateCheckMode: Tags
CurrentVersion: 1.30.1
......
......@@ -31,14 +31,7 @@ Builds:
gradle:
- yes
- versionName: 1.6.0
versionCode: 14
commit: v1.6.0
subdir: app
gradle:
- yes
AutoUpdateMode: Version v%v
UpdateCheckMode: Tags
CurrentVersion: 1.6.0
CurrentVersionCode: 14
UpdateCheckMode: Tags .*[0-9]$
CurrentVersion: 1.5.1
CurrentVersionCode: 13
......@@ -100,6 +100,7 @@ Builds:
- versionName: 0.15.0
versionCode: 741
disable: remove non-foss is wip
commit: v0.15.0
output: build/app/outputs/apk/fdroid/release/app-fdroid-release.apk
srclibs:
......
......@@ -86,41 +86,9 @@ Builds:
- mv $$openssl_for_ios_and_android$$/libs/x86/lib/*.a ../distribution/openssl/x86/lib/
ndk: r14b
- versionName: '4.3'
versionCode: 12
disable: fails to build
commit: '4.3'
subdir: app
sudo:
- apt-get update || apt-get update
- apt-get install -y ninja-build
gradle:
- yes
srclibs:
- openssl_for_ios_and_android@android_openssl-1.1.0f_curl-7.54.1
prebuild:
- sed -i -e 's/zlib \\/no-zlib \\/' $$openssl_for_ios_and_android$$/build-openssl4android.sh
- sed -i '/systemProp\.http\.proxy/d' ~/.gradle/gradle.properties
scandelete:
- app/CMakeFiles/
- distribution/
build:
- pushd $$openssl_for_ios_and_android$$
- ./build-openssl4android.sh android
- popd
- mv $$openssl_for_ios_and_android$$/libs/armeabi/lib/*.a ../distribution/openssl/armeabi/lib/
- pushd $$openssl_for_ios_and_android$$
- ./build-openssl4android.sh android-armeabi
- popd
- mv $$openssl_for_ios_and_android$$/libs/armeabi-v7a/lib/*.a ../distribution/openssl/armeabi-v7a/lib/
- pushd $$openssl_for_ios_and_android$$
- ./build-openssl4android.sh android-x86
- popd
- mv $$openssl_for_ios_and_android$$/libs/x86/lib/*.a ../distribution/openssl/x86/lib/
ndk: r14b
- versionName: '6.3'
versionCode: 17
disable: fails to build
commit: '6.3'
subdir: app
sudo:
......
......@@ -507,7 +507,7 @@ Builds:
subdir: app
gradle:
- yes
ndk: r20b
ndk: r21
AutoUpdateMode: Version v%v
UpdateCheckMode: Tags .*[0-9]$
......
......@@ -61,13 +61,6 @@ Builds:
gradle:
- yes
- versionName: 1.1.1
versionCode: 91
commit: 1.1.1
subdir: app
gradle:
- yes
- versionName: 1.2.1
versionCode: 93
commit: 1.2.1
......
......@@ -152,18 +152,7 @@ Builds:
../build.gradle
- sed -i -e 's/gradle-4.10/gradle-5.6.2/' gradle/wrapper/gradle-wrapper.properties
- versionName: '2.0'
versionCode: 22
commit: v2.0
subdir: app
gradle:
- yes
prebuild:
- sed -i -e 's/com.android.tools.build:gradle:3.2.0-alpha05/com.android.tools.build:gradle:3.1.2/g'
../build.gradle
- sed -i -e 's/gradle-4.10/gradle-5.6.2/' gradle/wrapper/gradle-wrapper.properties
AutoUpdateMode: Version v%v
AutoUpdateMode: None
UpdateCheckMode: Tags
CurrentVersion: '2.0'
CurrentVersionCode: 22
......@@ -57,6 +57,7 @@ Builds:
subdir: app
gradle:
- yes
ndk: r21
AutoUpdateMode: Version %v
UpdateCheckMode: Tags
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment