Commit 4224876a authored by Jochen Sprickerhof's avatar Jochen Sprickerhof
Browse files

Misc fixes

parent 5211327c
......@@ -102,6 +102,7 @@ Builds:
- versionName: 3.4.2
versionCode: 299
disable: old version code
commit: 3.4.2
subdir: app
gradle:
......
......@@ -99,7 +99,7 @@ Builds:
commit: 2.0.2
output: build/app/outputs/apk/release/app-release.apk
srclibs:
- flutter@1.25.0-8.1.pre
- flutter@2.0.3
prebuild: echo 'android.applicationVariants.all { variant -> variant.outputs.all
{ output -> outputFileName = "app-${output.baseName}.apk" } }' >> android/app/build.gradle
build:
......
......@@ -382,6 +382,8 @@ Builds:
- versionName: 2.6.0
versionCode: 180
disable: 'fails to build: DeveloperSettingsFragment.kt:16: Error: Upgrade Fragment
version to at least 1.3.0.'
commit: v2.6.0
subdir: app
gradle:
......@@ -390,6 +392,8 @@ Builds:
- versionName: 2.6.1
versionCode: 181
disable: 'fails to build: DeveloperSettingsFragment.kt:16: Error: Upgrade Fragment
version to at least 1.3.0.'
commit: v2.6.1
subdir: app
gradle:
......
......@@ -491,8 +491,6 @@ Builds:
gradle:
- yes
forceversion: true
rm:
- mobile/annotations.jar
scanignore:
- mobile/src/main/res/raw/datagz
......
......@@ -220,32 +220,6 @@ Builds:
- $$flutter$$/bin/flutter pub run build_runner build --delete-conflicting-outputs
- $$flutter$$/bin/flutter build apk --flavor fdroid
- versionName: 0.22.7
versionCode: 2207
commit: v0.22.7
output: build/app/outputs/flutter-apk/app-fdroid-release.apk
srclibs:
- flutter@1.22.4
build:
- $$flutter$$/bin/flutter config --no-analytics
- $$flutter$$/bin/flutter pub get
- $$flutter$$/bin/flutter pub run flutter_launcher_icons:main
- $$flutter$$/bin/flutter pub run build_runner build --delete-conflicting-outputs
- $$flutter$$/bin/flutter build apk --flavor fdroid
- versionName: 0.22.8
versionCode: 2208
commit: v0.22.8
output: build/app/outputs/flutter-apk/app-fdroid-release.apk
srclibs:
- flutter@1.22.4
build:
- $$flutter$$/bin/flutter config --no-analytics
- $$flutter$$/bin/flutter pub get
- $$flutter$$/bin/flutter pub run flutter_launcher_icons:main
- $$flutter$$/bin/flutter pub run build_runner build --delete-conflicting-outputs
- $$flutter$$/bin/flutter build apk --flavor fdroid
- versionName: 0.23.1
versionCode: 2301
commit: v0.23.1
......
......@@ -1903,6 +1903,8 @@ Builds:
- versionName: 3.5.4
versionCode: 354
disable: 'fails to build: Type com.blockstream.libwally.Wally$Obj is defined multiple
times'
commit: release_3.5.4
timeout: 25200
subdir: app
......
......@@ -24,6 +24,8 @@ Builds:
prebuild: sed -i -e 's,"https://kotlin.bintray.com/kotlinx","https://jitpack.io",g'
-e '/dl.bintray.com/d' -e 's,org.jetbrains.kotlin:kotlin-frontend-plugin,com.github.Kotlin.kotlin-frontend-plugin:kotlin-frontend,g'
build.gradle
scanignore:
- roboto/src/main/res/font/roboto_mono_regular.ttf
AutoUpdateMode: None
UpdateCheckMode: Tags
......@@ -49,6 +49,7 @@ Builds:
- versionName: v0.1.5-beta
versionCode: 6
disable: 'fails to build: resource drawable/band_6 not found.'
commit: v0.1.5-beta
subdir: app
gradle:
......
......@@ -360,7 +360,7 @@ Builds:
- libre
scanignore:
- app/src/main/assets/publicsuffixes
ndk: r21d
ndk: r21e
MaintainerNotes: |-
The file at `app/src/main/assets/publicsuffixes` is a version of the
......
......@@ -2713,6 +2713,7 @@ Builds:
- versionName: 9.8.4
versionCode: 255
disable: requires NDK 22 which is not compatible with OpenSSL 1.1.1 https://github.com/openssl/openssl/pull/13694
commit: v9.8.4
subdir: app
submodules: true
......
......@@ -26,6 +26,7 @@ Builds:
- versionName: 3.0.0
versionCode: 12
disable: old version code
commit: '3.0'
output: build/app/outputs/flutter-apk/app-release.apk
srclibs:
......
......@@ -30,6 +30,10 @@ Builds:
versionCode: 6
commit: v0.1.4-beta
subdir: app
sudo:
- apt-get update || apt-get update
- apt-get install -y openjdk-11-jdk
- update-alternatives --auto java
gradle:
- yes
......
......@@ -533,6 +533,8 @@ Builds:
- versionName: 15.1.0
versionCode: 36
disable: fails to build "baresip_link" is translated here but not found in default
locale
commit: v15.1.0
subdir: app
sudo:
......
......@@ -1654,6 +1654,8 @@ Builds:
- versionName: 29.1.0
versionCode: 161
disable: 'fails to build: "baresip_link" is translated here but not found in default
locale'
commit: 29.1.0
subdir: app
gradle:
......
......@@ -100,6 +100,7 @@ Builds:
- versionName: 2.3.2
versionCode: 26
disable: 'fails to build: USB.kt: (19, 27): Unresolved reference: io'
commit: 2.3.2
subdir: pretixprint/app
submodules: true
......
......@@ -49,6 +49,7 @@ Builds:
- versionName: 2.5.20
versionCode: 375
disable: fails to clone submodule toybox
commit: v2.5.20
subdir: app
submodules: true
......
......@@ -142,7 +142,7 @@ Builds:
- $$flutter$$/bin/flutter build apk --flavor foss
- versionName: 3.0.3
versionCode: 22
versionCode: 21
commit: v3.0.3
output: build/app/outputs/apk/foss/release/app-foss-release.apk
srclibs:
......
......@@ -178,7 +178,7 @@ Builds:
subdir: app
gradle:
- fdroid
prebuild: sed -i -e 's/21.0.6113669/21.3.6528147/' build.gradle
prebuild: sed -i -e 's/21.0.6113669/21.4.7075529/' build.gradle
ndk: r21e
AutoUpdateMode: Version %c
......
......@@ -282,6 +282,7 @@ Builds:
- versionName: 2.1.6
versionCode: 29
disable: 'fails to build: Unexpected token vm.js:80:10'
commit: 2.1.6
subdir: android/app
sudo:
......
......@@ -733,7 +733,7 @@ Builds:
submodules: true
gradle:
- fdroid
prebuild: echo 'org.gradle.jvmargs=-Xmx1g' >> ../gradle.properties
prebuild: echo -e '\norg.gradle.jvmargs=-Xmx1g' >> ../gradle.properties
scandelete:
- extern/bouncycastle/libs
- extern/bouncycastle/test
......@@ -748,7 +748,7 @@ Builds:
submodules: true
gradle:
- fdroid
prebuild: echo 'org.gradle.jvmargs=-Xmx1g' >> ../gradle.properties
prebuild: echo -e '\norg.gradle.jvmargs=-Xmx1g' >> ../gradle.properties
scandelete:
- extern/bouncycastle/libs
- extern/bouncycastle/test
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment