...
 
Commits (3)
ethstats (1.2.1-2) UNRELEASED; urgency=medium
* Bring up to compliance with Debian Policy 4.2.1: install the upstream
release notes (CHANGES) as NEWS and not changelog.
* Drop the Lintian overrides related to B-D: debhelper-compat -
Lintian 2.5.98 no longer emits these warnings and errors.
* Add a trivial autopkgtest running feature-check on the executable.
-- Peter Pentchev <roam@debian.org> Wed, 29 Aug 2018 17:17:28 +0300
ethstats (1.2.1-1) unstable; urgency=medium ethstats (1.2.1-1) unstable; urgency=medium
* Use my Debian e-mail address. * Use my Debian e-mail address.
......
...@@ -4,7 +4,7 @@ Priority: optional ...@@ -4,7 +4,7 @@ Priority: optional
Maintainer: Peter Pentchev <roam@debian.org> Maintainer: Peter Pentchev <roam@debian.org>
Build-Depends: debhelper-compat (= 11) Build-Depends: debhelper-compat (= 11)
Build-Depends-Indep: perl, feature-check Build-Depends-Indep: perl, feature-check
Standards-Version: 4.1.4 Standards-Version: 4.2.1
Homepage: https://devel.ringlet.net/net/ethstats/ Homepage: https://devel.ringlet.net/net/ethstats/
Vcs-Git: https://gitlab.com/ethstats/ethstats.git -b debian Vcs-Git: https://gitlab.com/ethstats/ethstats.git -b debian
Vcs-Browser: https://gitlab.com/ethstats/ethstats/tree/debian Vcs-Browser: https://gitlab.com/ethstats/ethstats/tree/debian
......
...@@ -4,5 +4,9 @@ ...@@ -4,5 +4,9 @@
override_dh_auto_install: override_dh_auto_install:
dh_auto_install -- PREFIX=/usr INSTALL_SCRIPT='install -m 755' dh_auto_install -- PREFIX=/usr INSTALL_SCRIPT='install -m 755'
override_dh_installchangelogs:
dh_installchangelogs -X CHANGES
install -m 644 CHANGES debian/ethstats/usr/share/doc/ethstats/NEWS
%: %:
dh $@ dh $@
# lintian does not understand the "debhelper-compat (= X)"
# build-dependency
ethstats source: debhelper-compat-file-is-missing
ethstats source: package-uses-deprecated-debhelper-compat-version 1
ethstats source: package-uses-debhelper-but-lacks-build-depends
ethstats source: package-lacks-versioned-build-depends-on-debhelper 1
ethstats source: missing-build-dependency debhelper
...@@ -4,3 +4,6 @@ Restrictions: allow-stderr ...@@ -4,3 +4,6 @@ Restrictions: allow-stderr
Test-Command: adequate ethstats Test-Command: adequate ethstats
Depends: @, adequate Depends: @, adequate
Test-Command: feature-check ethstats ethstats
Depends: @, feature-check