...
 
Commits (5)
ethstats (1.1.1-4) UNRELEASED; urgency=medium
* Use my Debian e-mail address.
* Declare compliance with Debian Policy 4.1.4 with no changes.
* Drop an empty line at the end of the changelog file.
* Add a trivial autopkgtest running adequate on the installed package.
* Use the B-D: debhelper-compat (= 11) mechanism.
-- Peter Pentchev <roam@debian.org> Thu, 17 May 2018 00:06:12 +0300
ethstats (1.1.1-3) unstable; urgency=medium
* Use substitution variables in the watch file.
......@@ -127,4 +137,3 @@ ethstats (1.0-1) unstable; urgency=low
* Initial Release. Closes: #143841
-- Scott M. Dier <sdier@debian.org> Sun, 21 Apr 2002 00:54:38 -0500
Source: ethstats
Section: net
Priority: optional
Maintainer: Peter Pentchev <roam@ringlet.net>
Build-Depends: debhelper (>> 11~)
Maintainer: Peter Pentchev <roam@debian.org>
Build-Depends: debhelper-compat (= 11)
Build-Depends-Indep: perl
Standards-Version: 4.1.3
Standards-Version: 4.1.4
Homepage: https://devel.ringlet.net/net/ethstats/
Vcs-Git: https://gitlab.com/ethstats/ethstats.git -b debian
Vcs-Browser: https://gitlab.com/ethstats/ethstats/tree/debian
......
......@@ -10,7 +10,7 @@ License: PD
Files: debian/*
Copyright: 2002, Scott M. Dier <sdier@debian.org>
2009 - 2011, 2015 - 2018, Peter Pentchev <roam@ringlet.net>
2009 - 2011, 2015 - 2018, Peter Pentchev <roam@debian.org>
License: PD
License: PD
......
# lintian does not understand the "debhelper-compat (= X)"
# build-dependency
ethstats source: debhelper-compat-file-is-missing
ethstats source: package-uses-deprecated-debhelper-compat-version 1
ethstats source: package-uses-debhelper-but-lacks-build-depends
ethstats source: package-lacks-versioned-build-depends-on-debhelper 1
ethstats source: missing-build-dependency debhelper
Test-Command: env TEST_SCRIPT='/usr/bin/ethstats' make test
Depends: @, make
Restrictions: allow-stderr
Test-Command: adequate ethstats
Depends: @, adequate