buildserver: allow gradle to install newer build-tools versions

gradle will now automatically download and install missing bits of the
Android SDK.  While we prefer to have the SDK packages fully verified, we
should allow this behavior on the buildserver to ensure that builds work
even when the buildserver can't be updated.  Since each build starts from a
clean snapshot, this auto-installed build-tools will only be used for the
single build, so it won't affect other apps.
1 job for constraintlayout-license-bullshit in 27 minutes and 56 seconds (queued for 17 seconds)
Status Job ID Name Coverage
  Test
passed #12196499
test

00:27:56