Commit a74777e5 authored by David Lucadou's avatar David Lucadou

Updated gems

parent b41c3c4a
Pipeline #60168393 passed with stage
in 8 minutes and 16 seconds
......@@ -28,7 +28,7 @@ gem 'uglifier', '>= 1.3.0'
gem 'nokogiri', '~> 1.10.1'
# Use CoffeeScript for .coffee assets and views
gem 'coffee-rails', '~> 4.2'
gem 'coffee-rails', '~> 5.0.0'
# Turbolinks makes navigating your web application faster. Read more: https://github.com/turbolinks/turbolinks
gem 'turbolinks', '~> 5'
# Build JSON APIs with ease. Read more: https://github.com/rails/jbuilder
......@@ -72,7 +72,7 @@ gem 'devise-two-factor', '~>3.0.3'
gem 'rqrcode-rails3', '~>0.1.7'
gem 'mini_magick', '~>4.9.3'
gem 'attr_encrypted', '~> 3.1.0'
gem 'webauthn', '~> 1.9.0'
gem 'webauthn', '~> 1.14.0'
gem 'rollbar', '~> 2.16'
# Clipboard.JS
......@@ -87,7 +87,7 @@ group :development, :test do
gem 'byebug', platforms: [:mri, :mingw, :x64_mingw]
gem 'pry-byebug'
# Adds support for Capybara system testing and selenium driver
gem 'capybara', '~> 3.12'
gem 'capybara', '~> 3.18'
gem 'webdrivers', '~> 3.0'
gem 'headless'
gem 'selenium-webdriver'
......@@ -101,7 +101,7 @@ end
group :development do
# Access an IRB console on exception pages or by using <%= console %> anywhere in the code.
gem 'web-console', '>= 3.3.0'
gem 'web-console', '>= 3.7.0'
gem 'listen', '>= 3.0.5', '< 3.2'
# Spring speeds up development by keeping your application running in the background. Read more: https://github.com/rails/spring
gem 'spring'
......
......@@ -47,9 +47,10 @@ GEM
arel (9.0.0)
attr_encrypted (3.1.0)
encryptor (~> 3.0.0)
autoprefixer-rails (9.5.1)
autoprefixer-rails (9.5.1.1)
execjs
bcrypt (3.1.12)
bindata (2.4.4)
bindex (0.7.0)
bootstrap (4.3.1)
autoprefixer-rails (>= 9.1.0)
......@@ -62,7 +63,7 @@ GEM
builder (3.2.3)
byebug (11.0.1)
callsite (0.0.11)
capybara (3.16.2)
capybara (3.18.0)
addressable
mini_mime (>= 0.1.3)
nokogiri (~> 1.8)
......@@ -71,21 +72,21 @@ GEM
regexp_parser (~> 1.2)
xpath (~> 3.2)
cbor (0.5.9.3)
childprocess (0.9.0)
ffi (~> 1.0, >= 1.0.11)
childprocess (1.0.1)
rake (< 13.0)
chunky_png (1.3.11)
clipboard-rails (1.7.1)
coderay (1.1.2)
coffee-rails (4.2.2)
coffee-rails (5.0.0)
coffee-script (>= 2.2.0)
railties (>= 4.0.0)
railties (>= 5.2.0)
coffee-script (2.4.1)
coffee-script-source
execjs
coffee-script-source (1.12.2)
concurrent-ruby (1.1.5)
cose (0.1.0)
cbor (~> 0.5.9.2)
cose (0.6.1)
cbor (~> 0.5.9)
crass (1.0.4)
devise (4.6.2)
bcrypt (~> 3.0)
......@@ -105,8 +106,8 @@ GEM
execjs (2.7.0)
factory_bot (5.0.2)
activesupport (>= 4.2.0)
factory_bot_rails (5.0.1)
factory_bot (~> 5.0.0)
factory_bot_rails (5.0.2)
factory_bot (~> 5.0.2)
railties (>= 4.2.0)
faraday (0.15.4)
multipart-post (>= 1.2, < 3)
......@@ -154,7 +155,7 @@ GEM
activerecord
kaminari-core (= 1.1.1)
kaminari-core (1.1.1)
libv8 (6.7.288.46.1)
libv8 (7.3.492.27.1)
listen (3.1.5)
rb-fsevent (~> 0.9, >= 0.9.4)
rb-inotify (~> 0.9, >= 0.9.7)
......@@ -167,17 +168,17 @@ GEM
mini_mime (>= 0.1.1)
marcel (0.3.3)
mimemagic (~> 0.3.2)
meta_request (0.6.0)
meta_request (0.7.0)
callsite (~> 0.0, >= 0.0.11)
rack-contrib (>= 1.1, < 3)
railties (>= 3.0.0, < 6)
railties (>= 3.0.0, < 7)
method_source (0.9.2)
mimemagic (0.3.3)
mini_magick (4.9.3)
mini_mime (1.0.1)
mini_portile2 (2.4.0)
mini_racer (0.2.4)
libv8 (>= 6.3)
mini_racer (0.2.5)
libv8 (>= 6.9.411)
minitest (5.11.3)
moment-timezone-rails (1.0.0)
momentjs-rails (>= 2.10.5, <= 3.0.0)
......@@ -187,9 +188,8 @@ GEM
multi_xml (0.6.0)
multipart-post (2.0.0)
nenv (0.3.0)
net_http_ssl_fix (0.0.10)
nio4r (2.3.1)
nokogiri (1.10.2)
nokogiri (1.10.3)
mini_portile2 (~> 2.4.0)
notiffany (0.1.1)
nenv (~> 0.1)
......@@ -292,7 +292,7 @@ GEM
rspec-mocks (~> 3.8.0)
rspec-core (3.8.0)
rspec-support (~> 3.8.0)
rspec-expectations (3.8.2)
rspec-expectations (3.8.3)
diff-lcs (>= 1.2.0, < 2.0)
rspec-support (~> 3.8.0)
rspec-mocks (3.8.0)
......@@ -312,15 +312,15 @@ GEM
sassc (2.0.1)
ffi (~> 1.9)
rake
sassc-rails (2.1.0)
sassc-rails (2.1.1)
railties (>= 4.0.0)
sassc (>= 2.0)
sprockets (> 3.0)
sprockets-rails
tilt
securecompare (1.0.0)
selenium-webdriver (3.141.0)
childprocess (~> 0.5)
selenium-webdriver (3.142.1)
childprocess (>= 0.5, < 2.0)
rubyzip (~> 1.2, >= 1.2.2)
shellany (0.0.1)
spring (2.0.2)
......@@ -352,14 +352,14 @@ GEM
activemodel (>= 5.0)
bindex (>= 0.4.0)
railties (>= 5.0)
webauthn (1.9.0)
cbor (~> 0.5.9.2)
cose (~> 0.1.0)
webauthn (1.14.0)
bindata (~> 2.4)
cbor (~> 0.5.9)
cose (~> 0.6.0)
jwt (>= 1.5, < 3.0)
openssl (~> 2.0)
securecompare (~> 1.0)
webdrivers (3.7.2)
net_http_ssl_fix
webdrivers (3.8.0)
nokogiri (~> 1.6)
rubyzip (~> 1.0)
selenium-webdriver (~> 3.0)
......@@ -377,9 +377,9 @@ DEPENDENCIES
bootstrap (~> 4.3.1)
bootstrap4-datetime-picker-rails (~> 0.3.1)
byebug
capybara (~> 3.12)
capybara (~> 3.18)
clipboard-rails (~> 1.7.1)
coffee-rails (~> 4.2)
coffee-rails (~> 5.0.0)
devise (~> 4.6.1)
devise-two-factor (~> 3.0.3)
factory_bot_rails (~> 5.0.1)
......@@ -420,8 +420,8 @@ DEPENDENCIES
turbolinks (~> 5)
tzinfo-data
uglifier (>= 1.3.0)
web-console (>= 3.3.0)
webauthn (~> 1.9.0)
web-console (>= 3.7.0)
webauthn (~> 1.14.0)
webdrivers (~> 3.0)
RUBY VERSION
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment