Commit dd54ef82 authored by Jonas L.'s avatar Jonas L.

Update dependencies

parent efd7551c
......@@ -48,14 +48,14 @@ dependencies {
implementation 'io.resourcepool:ssdp-client:2.1.0'
implementation 'androidx.lifecycle:lifecycle-extensions:2.0.0'
implementation 'androidx.lifecycle:lifecycle-common-java8:2.0.0'
implementation 'com.squareup.okhttp3:okhttp:3.10.0'
implementation 'com.squareup.okhttp3:okhttp:3.11.0'
implementation 'androidx.legacy:legacy-support-v4:1.0.0'
testImplementation 'junit:junit:4.12'
androidTestImplementation 'androidx.test:runner:1.1.0-alpha4'
androidTestImplementation 'androidx.test.espresso:espresso-core:3.1.0-alpha4'
implementation 'androidx.room:room-runtime:2.0.0'
kapt 'androidx.room:room-compiler:2.0.0'
implementation "androidx.room:room-runtime:$room_version"
kapt "androidx.room:room-compiler:$room_version"
implementation "me.henrytao:recycler-pager-adapter:2.1.0"
implementation 'com.squareup.picasso:picasso:2.71828'
implementation "android.arch.work:work-runtime-ktx:$work_version"
implementation 'android.arch.work:work-runtime-ktx:1.0.0-alpha09'
}
......@@ -2,17 +2,14 @@
buildscript {
ext.kotlin_version = '1.2.71'
ext.lifecycle_version = '1.1.1';
ext.room_version = "1.1.0"
ext.gradle_version = '3.2.0'
ext.work_version = "1.0.0-alpha02"
ext.room_version = "2.0.0"
repositories {
google()
jcenter()
}
dependencies {
classpath "com.android.tools.build:gradle:$gradle_version"
classpath 'com.android.tools.build:gradle:3.2.0'
classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
// NOTE: Do not place your application dependencies here; they belong
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment