Commit 89ffc704 authored by Tjerk Vreeken's avatar Tjerk Vreeken

Pin CasADi and Pymoca versions

These two packages are relatively unstable or known to make
substantial (backwards-incompatible) changes. We therefore pin them to
release series known/expected to work, while allowing bug fixes using a
wildcard specifier.
parent b4141be4
......@@ -41,10 +41,10 @@ setup(
platforms = ['Windows', 'Linux', 'Mac OS-X', 'Unix'],
packages = find_packages("src"),
package_dir = {"": "src"},
install_requires = ["casadi >= 3.2.0",
install_requires = ["casadi == 3.4.*",
"numpy >= 1.14.0",
"scipy >= 1.0.0",
"pymoca >= 0.2.6"],
"pymoca == 0.3.*"],
tests_require = ['nose'],
test_suite = 'nose.collector',
python_requires='>=3.5',
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment