Commit 72e691b8 authored by Jorn Baayen's avatar Jorn Baayen

Since pymola and casadi are available using pip, we do not need the mock module any longer.

parent 5b72fbce
casadi >= 3.2.0
numpy >= 1.11.0 numpy >= 1.11.0
mock >= 2.0.0 scipy
numba
pymola
sphinx sphinx
sphinx_rtd_theme sphinx_rtd_theme
matplotlib matplotlib
......
casadi >= 3.2.0 casadi >= 3.2.0
numpy numpy >= 1.11.0
scipy
numba numba
pymola pymola
\ No newline at end of file
...@@ -13,17 +13,3 @@ print( ...@@ -13,17 +13,3 @@ print(
For more information visit https://www.deltares.nl/en/software/rtc-tools/ For more information visit https://www.deltares.nl/en/software/rtc-tools/
***************************************************************************** *****************************************************************************
""".format(__version__)) """.format(__version__))
# Import dependencies
try:
import casadi
except ImportError:
# Don't require casadi for readthedocs.org
from mock import MagicMock
import warnings
import sys
warnings.warn("CasADi not found. Please ensure that casadi can be imported before running RTC-Tools.")
MOCK_MODULES = ['casadi', 'pymola', 'pylab', 'scipy', 'scipy.interpolate']
sys.modules.update((mod_name, MagicMock()) for mod_name in MOCK_MODULES)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment