Commit 13d701be authored by Tjerk Vreeken's avatar Tjerk Vreeken

Lower version requirement to Python 3.5

There is no reason not to support Python 3.5 as well, which happens to
be the default on many systems at time of writing.

Also include the python_requires argument, which is respected by
versions of pip >= 9.0.0.
parent 5ec10f94
......@@ -7,8 +7,8 @@ from setuptools import setup, find_packages
import versioneer
import sys
if sys.version_info[0] == 3 and sys.version_info[1] < 6:
sys.exit("Sorry, Python 3.6 or newer is required.")
if sys.version_info < (3, 5):
sys.exit("Sorry, Python 3.5 or newer is required.")
DOCLINES = __doc__.split("\n")
......@@ -48,5 +48,6 @@ setup(
install_requires = install_reqs,
tests_require = ['nose'],
test_suite = 'nose.collector',
python_requires='>=3.5',
cmdclass = versioneer.get_cmdclass(),
)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment