Commit e4041448 authored by Maciej Delmanowski's avatar Maciej Delmanowski

Fix ansible-lint error E403 in DebOps roles

parent 97213da5
......@@ -10,7 +10,7 @@
- name: Ensure required packages are installed
apt:
name: '{{ item }}'
state: 'latest'
state: 'present'
install_recommends: False
with_flattened: '{{ btrfs__base_packages }}'
register: btrfs__register_packages
......
......@@ -6,7 +6,7 @@
- name: Install auth-related packages
apt:
name: '{{ item }}'
state: 'latest'
state: 'present'
install_recommends: 'no'
with_items: '{{ auth_packages }}'
register: auth__register_packages
......
---
- name: Install Box Backup client package
apt: pkg=boxbackup-client state=latest install_recommends=no
apt: pkg=boxbackup-client state=present install_recommends=no
register: boxbackup__register_client_packages
until: boxbackup__register_client_packages is succeeded
......
---
- name: Install Box Backup server packages
apt: pkg=boxbackup-server state=latest install_recommends=no
apt: pkg=boxbackup-server state=present install_recommends=no
register: boxbackup__register_server_packages
until: boxbackup__register_server_packages is succeeded
......
......@@ -3,7 +3,7 @@
- name: Install required packages
apt:
name: '{{ item }}'
state: 'latest'
state: 'present'
install_recommends: False
with_flattened:
- '{{ gitlab__base_packages }}'
......
......@@ -3,7 +3,7 @@
- name: Install libvirt support
apt:
name: '{{ item }}'
state: 'latest'
state: 'present'
install_recommends: False
with_flattened:
- '{{ libvirt__base_packages }}'
......
......@@ -3,7 +3,7 @@
- name: Install OpenVZ kernel
apt:
name: '{{ openvz_kernel_name }}'
state: 'latest'
state: 'present'
install_recommends: False
register: openvz_kernel_status
until: openvz_kernel_status is succeeded
......
......@@ -21,7 +21,7 @@
- name: Install OpenVZ packages
apt:
name: '{{ item }}'
state: 'latest'
state: 'present'
install_recommends: False
with_items: [ 'vzctl', 'vzquota', 'vzdump', 'ploop', 'uuid-runtime' ]
register: openvz__register_packages
......
---
- name: Install dbconfig-common
apt: pkg=dbconfig-common state=latest install_recommends=no
apt: pkg=dbconfig-common state=present install_recommends=no
register: phpmyadmin__register_dbconfig_packages
until: phpmyadmin__register_dbconfig_packages is succeeded
......@@ -11,7 +11,7 @@
owner=root group=root mode=0600
- name: Install PHPMyAdmin packages
apt: pkg=phpmyadmin state=latest install_recommends=no
apt: pkg=phpmyadmin state=present install_recommends=no
register: phpmyadmin__register_packages
until: phpmyadmin__register_packages is succeeded
......
......@@ -23,7 +23,7 @@
- name: Install PKI packages
apt:
name: '{{ item }}'
state: 'latest'
state: 'present'
install_recommends: False
cache_valid_time: '{{ ansible_local.core.cache_valid_time
if (ansible_local|d() and ansible_local.core|d() and
......
---
- name: Install app packages
apt: pkg={{ item }} state=latest install_recommends=False
apt: pkg={{ item }} state=present install_recommends=False
with_items: '{{ rails_deploy_packages + [ "git" ] }}'
register: rails_deploy__register_packages
until: rails_deploy__register_packages is succeeded
......
......@@ -3,7 +3,7 @@
- name: Install inoticoming package
apt:
name: 'inoticoming'
state: 'latest'
state: 'present'
install_recommends: False
register: reprepro__register_inotincoming
until: reprepro__register_inotincoming is succeeded
......
......@@ -22,7 +22,7 @@
- name: Install Salt Master packages
package:
name: '{{ item }}'
state: 'latest'
state: 'present'
with_flattened:
- '{{ salt__base_packages }}'
- '{{ salt__packages }}'
......
......@@ -4,7 +4,7 @@
- name: Install Samba packages
apt:
pkg: '{{ item }}'
state: 'latest'
state: 'present'
install_recommends: False
with_flattened:
- '{{ samba__base_packages }}'
......
......@@ -3,7 +3,7 @@
- name: Install SKS Keyserver
apt:
name: 'sks'
state: 'latest'
state: 'present'
install_recommends: 'no'
register: sks__register_packages
until: sks__register_packages is succeeded
......
......@@ -3,7 +3,7 @@
- name: Install ldapscripts packages
apt:
name: '{{ item }}'
state: 'latest'
state: 'present'
install_recommends: False
with_items: [ 'ldapscripts', 'ldap-utils', 'pwgen' ]
register: slapd__register_ldapscripts_packages
......
......@@ -21,7 +21,7 @@
- name: Install OpenLDAP packages
apt:
name: '{{ item }}'
state: 'latest'
state: 'present'
install_recommends: False
with_items: [ 'slapd', 'ldap-utils', 'python-ldap' ]
register: slapd__register_packages
......
---
- name: Install SMS Tools packages
apt: name={{ item }} state=latest install_recommends=no
apt: name={{ item }} state=present install_recommends=no
with_items: [ 'smstools', 'xinetd', 'libconfig-tiny-perl' ]
register: smstools__register_packages
until: smstools__register_packages is succeeded
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment